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Creation of a guitar body 

The purpose of this first section is to create the body of a guitar in 
order to review some of the functions addressed during the first 
training cycle. 

Concepts addressed: 

 Sketch: Line, arc, sketch copy, dimensions and constraints 
 Extrusion 
 Wood machinings: Pockets, drillings and mouldings 
 Data structure: Part definition 

Creation of the body 

Start the sketch 

 Create a new Design document.  
In the advanced parameters, select Without template. Select the Associative design 
mode and then the Millimeters unit. 

 Click on OK to confirm. 

 Activate the Sketch context , and then select New sketch.  

 Select Current coordinate system.  

 Draw a first line 1 as shown opposite using the Axes (Z) = YES mode. 

  

 Apply a coincidence constraint of this line to the Y axis.  >  

 Dimension this line with a nominal value of 80mm.  

 After applying the value, select Symmetry constraint in the dialog bar, and then select X 
as the symmetry axis. 

  

 
Note: Applying a symmetry constraint to a dimension allows the dimension to be 
automatically centered on the selected axis, regardless of its length. 
 
 

 
 

 Use the Circle function  in Passing point mode 
to draw the two circle arcs 2 and 3 as shown 

opposite.  

 Draw the line 4 after the circle arc 3 as shown 
opposite. 

  



Creation of a guitar body  TopSolid'Wood Advanced 

2   Missler Software 

 Dimension the point between the segments 2 and 3 and 
the two points of line 4. 

 Modify the dimension values and apply the values shown 

opposite.  

 Apply a tangency constraint between 1 and 2 and 
between 2 and 3 

 
Note: All the sketch elements are green, which means they 
are totally constrained. 
 
 
 
 
 

 Apply a tangency constraint between the circle arc 3 and 
the line 4. 

 
Note: The sketch was already fully constrained. Adding a 
constraint makes the design overconstrained and the 
document is invalid (a question mark icon appears in the title 
bar of the software). Extra constraints and dimensions must 
be deleted. 
 

 Remove the dimension on X (vertical dimension) of 
200mm from the right point of the line. 

 

 Select Show extremities.  
 
Note: The Show extremities function displays: 

 The two ends of an open contour using dotted circles. 
 The area of a closed contour using hatch lines. If the sketch contains several closed profiles, each of them 

will have a different hatching pattern with a different color. 
 
This design mode makes it easy to see whether the contour being created is closed or open and, if so, quickly see 
where it is open. 
 

Open contour Closed contour 
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 Select Modify height.  
 
Note: The Modify height function allows you, in the current sketch, to adjust: 

 the height for dimensions; 
 the height for constraints; 
 The circle radii at the ends of open profiles. 

These values are saved per sketch. You can modify these default values in Tools > Options > Sketch. 

 Adjust: 

 Constraints height: 12 
 Circle radius for profile extremities: 8 

 

 Validate these settings with OK. 
 

 Draw 4 circle arcs (5, 6, 7 and 8) in Passing point mode as shown below. 

 Then dimension the points with the values specified below. 

 Apply tangency constraints between the arcs 5 and 6, 6 and 7, 6 and 7 and 7 and 8. 

 Also apply a tangency constraint between the line 4 and the arc 5. 
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Copy the sketch 

 Start the Copy function.  

 Using the selection function (lasso), select 
the segments 2, 3, 4, 5, 6, 7 and 8. 

  

 Click on OK to confirm.  

 Select Simple mirror as the propagation. 

 
 

 Select the ZX plane as the symmetry 

plane.  
 
 
 
 
 

 Dimension the points of the copied 
elements. 
Do not change the values of these 
dimensions. 

 In order not to overconstrain the 
sketch, remove the dimension on X 
(vertical dimension) of 200mm 
from the right point of line 4'. 

 

 Then apply a tangency constraint 
between 1 and 2'. 

 
 
 
 
 
 
 

 
 

 Use the Modify parameter function to change the dimension values of arcs 

6', 7' and 8' as shown opposite.  
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Close the sketch 

 Draw two lines 9 and 10 between arcs 8 and 8' as shown opposite. 
 
Note: Once the contour is closed, the hatch lines are displayed. 

 

 Apply: 

 an orientation constraint along X to the line 9; 
 a perpendicularity constraint between lines 9 and 10. 

 
 
 
 
 

 Select the Fillet function.   

 Adjust: 

 Mode = Global 
 Fillet radius = 5mm. 

 
 
Note: The Global mode is used to apply the fillet onto all the sketch's vertices, except onto tangent vertices and 
vertices where the fillet cannot be performed. 

 Select the contour as the curve to modify. 

Note: The fillets that will be created are previewed in red. Yellow circles are shown on vertices where the fillets 
cannot be performed. 

 Validate the fillets using the Compute fillet(s) button.  

 End the sketch. 
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Extrude the body 

 From the Shape context, select Extruded.  

 Select the previously drawn sketch in Section 
curves or texts. 

 Extrude the body to a height of 35mm. 

 

 Save this document: 

 Answer No to the request for a part definition. 
 Create a new folder named Guitar body and rename this file to Guitar body. 

Creation of operations 

Create the pockets 

 Make layer 1 current.  

 From the Sketch context, select Contour > 
Rectangular. 

 Draw a rectangle as shown opposite and select 

Auto dimension  to automatically 
place the dimensions of the rectangle.  

 
 

 Use the Modify parameter function to change the values to 73mm on 
the X axis and to 52mm on the Y axis. 

 Apply two coincidence constraints: 

 between the segment 1 of the rectangle and the edge 3 of the guitar; 
 between the segment 2 of the rectangle and the edge 4 of the guitar. 

 Apply a fillet with a radius = 5mm in Local mode onto the rectangle's left 
angles. 

 
 

 Draw two new rectangular contours in Constraints = Perpendicularity mode. 

 

 Select Auto dimension to place the dimensions of rectangles. 

 Use Modify parameter  to change the dimensions of rectangles: 

 15mm on X and 60mm on Y for rectangle 2; 
 18mm on X and 70mm on Y for rectangle 3. 

 Start the Modify element function. 

 Select the vertical dimension of rectangle 3 (70mm) and select Constraint on X. 
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 Repeat the procedure on the rectangle's 2 vertical dimension (60mm). 

 

 Dimension: 

 the distance between rectangles 1 and 2 to 20mm; 
 the angle between the left side of rectangle 3 and the X axis of the coordinate system to 105°; 
 the distance between the left side of rectangle 2 and the bottom right point of rectangle 3 to 100mm. 

 

 Apply fillets with a radius = 7mm onto the angles of rectangles 2 and 3. 

 

 

 End the sketch. 
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 From the Wood context, select Pocket.  

 Select the top of the guitar body as the reference face. 

 Set Generatrix = Hidden and Generatrix sketch = Global. 

 

Note: The Generatrix = Hidden mode is used to hide the current sketch once the pocket is performed. 
The Generatrix sketch = Global mode generates a pocket for each contour of the sketch in one single operation. 
This means that all the pockets will have the same characteristics. 

 Select the drawn sketch in Curve(s). 

The Pocket parameters window opens. 

 Adjust: 

 Through: No 
 Depth: 15mm 

 Validate the window with OK to create the pockets. 
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Create the drillings 

 Start the Drilling function.  

 Set Coordinate system = Constraint, Mode = Dynamic and Hook = Current coordinate system 

 

Note: The Dynamic mode allows a drilling to be positioned and dimensioned at the same time. 
The Hook = Current coordinate system mode is used to place the drilling dimensions in relation to the current 
coordinate system 

 

 Position the drilling on the top face of the 
guitar body at 85mm in the X+ direction 
and 87mm in the Y- direction 

 
Note: The hooking of the drilling in dynamic 
mode is made based on the precision of the 
step defined in the grid. 
If the value of the dimension is not exact, it will 
be possible to modify it later using the Modify 
parameter function. 
 
 

 In Drilling models, select Hole and adjust the following parameters: 

 Hole: Through one 
 Diameter: 15mm 

 

 Once the drilling has been performed, select Propagate in the dialog bar.  

 Select Linear propagation in the X+ direction, and then enter Distance per instance = 50mm and Total 
number = 2. 

  

 Then make a third drilling: 

 185mm in the X+ direction and 87mm in the Y- direction 
 Hole 
 Through, Diameter: 7mm 
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Create the moulding 

 Start the Moulding function.  

 Select Sweep = Planar face to perform a standard 
moulding on a planar face. 

 Select the top of the guitar body as the reference 
face. 

 

 Set Join edges = YES and Follow tangent edges = YES 
 
 
 
 

 Select the guitar contour's edge as the reference edge or curve for tool path. Validate the selection with 

Stop.  

 Validate the default direction of arrows with OK.  
 
The Parameters window for the moulding opens. 
 

 From the Standard TopSolid'Wood drop-down list, select Groove mill in 
the Mill category 

 Set an entry and an exit with a radius = 0mm. 

 Set Parameters = Axis and Z dimension = 3mm 
 

 Validate with OK to create the moulding. 

 Use Copy operation to create the same moulding on the base of the guitar. 
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Create the groove 

 Make layer 2 current.  

 

 Start a new sketch. 

 Draw a horizontal line in Axes (Z) = YES mode. 

 
 Apply an alignment constraint to this line with the X 

axis. 

 Apply two coincidence constraints:  

 of the left point of the line on the left pocket; 
 of the right point of the line on the middle pocket. 

 

 End the sketch. 
 

 Create a groove on the top face with the drawn line as the tool path and the guitar body as the shape to 

profile.  

 From the Parameters window of the groove, adjust: 

 Tool type: Routers  
 Standard: TopSolid'Wood 
 Mill > Simple mill 
 Parameters: Centered 
 Gap distance: 0mm 
 Groove width: 5mm 
 Groove depth: 5mm 

 

 Validate the parameters with OK. 
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Part definition 

 Use the Wood > Define > Define part function to define the guitar body: 

 Designation: Guitar body 
 Material: TopSolid'Wood > Hardwoods > Ash european. 

 From the Cutting-up tab, add 30mm over dimensions in 
length and width in Additional mode. 

 
 
 

Note: It is possible with an option to view the part stock as shown below. Viewing the stock is helpful to validate 
it. However, it is not recommended to work with the stock displayed. 

 From the Part definition window, open the Stock tab. 

 Check the Make stock box and validate the window with OK. 

 

 Start the Define part function. 

 Select the guitar as the part to define. 

 Select Characteristics.  

 From the Stock tab, uncheck Make stock. 

 Save the document. 
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Introduction to components 
When creating design projects, the user often or always needs to use production standards. These standards can 
be for example: 

 Hardware parts (screws, dowels, hinges, slides…) 
 Interior design components (cabinets, doors, shelves, separation panels…) 
 Complete furniture (coffee table, counter, door…) 

 
They allow information to be centralized and the component to be designed only once to help minimize the time 
it is used in projects. 
 

Creation of a library 

 Create a new Design document. 

 Open the options using Tools > Options. 
 
 
 
 
 

 From the Component > User library category, add a user library using the Add 
button. 

 
 

 Enter Name: Training library. 

 Select Path: C:\Projet and create a new folder named Training library. 

 

 Click on Add to create this new library. 

 

 Click on OK to validate the options. 
 
Note: In order to preserve you library components, it is not recommended that you modify and save the 
components of the TopSolid standard libraries (My 3D Standard, TopSolid'Wood, AFNOR…).  
To modify and use the standard library components, it is better to save them in your own libraries. 
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Exercise 1: Creation of a shelf 

The goal of this exercise is to create the different parts of the shelf as constrained blocks, and then assemble 
them. This shelf will be saved in the library. 

Concepts addressed: 

 Parameters 
 Construction volume 
 Constrained blocks 
 Defining the parts and set 
 Assembling the parts 
 Saving in the library 

Designing the construction volume 

Create the parameters 

 Create a new Design document . From the Advanced parameters, select Without template. 

 Use the Parameter > Create function to create the following four parameters in Unit type = Length mode. Do 
not display the texts of the parameters. 

 Value = 1200; Name: l; Designation: Shelf length 
 Value = 400; Name: d; Designation: Shelf depth 
 Value = 300; Name: h; Designation: Shelf height 
 Value = 19; Name: t; Designation: Panel thickness 

 

 >  

Create the construction volume 

 From the Shape context , start the Block function , and then enter X length = l, Y length = d and Z 
length = h. 

 

 

 Select the center of the absolute coordinate system as the alignment point. 

 Start the Attribute > Transparency function to apply a transparency of 7 to this block. 
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Creation of parts 

Bottom part 

 Make layer 1 current.  

 From the Wood context , start the Constrained block function.  

 Define the t parameter as the thickness, and then select: 

 the left-hand side of the construction block as the first plane. 

 

 the right-hand side of the construction block as the second plane or point.  

 

 the front face of the construction volume as the first plane. 
 the back face of the construction volume as the second plane or point. 
 the bottom face of the construction volume as the positioning plane. 

 Adjust the positioning of the constrained block using the yellow arrows to place the part inside the 
construction volume. 

 

Top part 

 Create a new constrained block to make the part below: 

 Thickness = t 
 First plane: Select the left-hand face of the construction volume. 
 Second plane: Set Mode = Faces, enter Second shift = (2/3)*l, and then select the right-hand face of the 

construction volume 

 
 First plane/Second plane: Select the front and back faces of the construction volume. 
 Positioning plane: Select the top face of the construction volume. 
 Position the constrained block inside the construction volume. 
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Side part 

 Turn off layer 0. 

 Using the constrained block, create the following part: 

 The constrained block has a thickness = t. 
 

 

Definition of parts and set 

Define the parts 

 Define the parts using Wood > Define > Define part: 

 Bottom part designation: Bottom shelf 
 Top part designation: Top shelf 
 Side part designation: Shelf side 

 For the three parts, select the material TopSolid'Wood > Hardwoods > Birch apple. 

 The grain orientation of the part must be placed on the height. Use the Invert axes button in the Cutting-up 
tab to rotate the part's cutting-up axes. 

 

 
 

Note: In TopSolid'Wood, the length of a part always matches its grain orientation. 

Define the set 

Note: Once at least two parts have been defined, you 
are asked whether you want to define the assembly 
automatically in order to structure data. 

 Define the set by validating the dialog with Yes. 

 Designation: Wall shelf 
 Assembly nature: Sub-assembly 
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Assembling the shelf 

 From the Wood context, start the Dowel assembly function.  

 Select Wood dowel and select the D12 L35 code. 
 

 In the dialog bar, select the Filter mode and set Propagation = YES. 

 

 Select: 

 the contact face between the side et the top as the support face. Use 
the rotating selection to select this face. 

 
 

 the front edge of the top as the start face or edge. 

 Centred automatically.  

Note: The Centred automatically option is used to automatically center the assembly in the thickness of the part. 

 the rear face of the top as the terminate face or edge. 

 From the Distribution definition window, select the Advanced mode. 

 

Note: The Advanced mode is used to provide minimum start and terminate distances for the dowels, as well as a 
step between the dowels. The quantity of dowels will be automatically calculated. 
 

  Then adjust the following parameters: 

 Step: 96mm 
 Minimum distance to start: 50mm 
 Minimum distance to terminate: 50mm 

 Validate with OK to position the dowels. 

 Select Copy propagation, and then repeat the operation to assemble the 

side with the bottom shelf.  
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Saving work in library 

Define the parameters as drivers 

Note: Defining parameters as drivers allows their values to be modified when inserting the component in an 
assembly file. 

 Start the Assembly > Define component > Define drivers function. 

 

 Enter the l parameter as the driving element to insert. 

 

 Press Enter to validate. 

 Press Enter again to validate the parameter designation. 

 Define the parameters d, h and t in the same way. 

Save the component in the library 

 Use the Assembly > Define component > Edit/save template function. 

 
 

 Select Save standard template. 

 

Note: The Save standard template option is used to save a file in the component library. 
The Edit standard template option allows you to edit a file already saved in the library 
 

 From the Standard drop-down list, select the library you created: Training Library. 

 Enter: 

 New family: Furniture 
 New type: Shelves 
 New variant: Wall shelf 

Note: The families, types and variants correspond to the different levels of the component library.  

 

 Enter New version: 00. 

Note: A new version of a component is created when a number of changes have been made to that component. 
This new component will be saved in a new file. 

Thus, assemblies using the old version of the component are not modified and you can use the new version for 
new assemblies. 
 

 Uncheck Supplier code and check Purge operations geometry 

Note: The Purge operations geometry option improves the calculation performance of components. 
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Note: Once the component has been saved in the library, the text $STD=LibraryName is displayed before the file 
name in the software title bar. 

   

Once the file has been saved in the library, click the disk icon to save the changes made to the file.  

Supplement: Creation of supports 

Create the shelf supports 

 Make layer 2 current. 

 Start a new sketch and draw two circles 20mm in 
diameter as shown opposite. 

 
 
 
 
 
 
 

 Use the Dimension function to dimension the 
center of the circle with the top shelf's edges to 

50mm as shown opposite.  
 
 
 
 
 
 
 
 
 

 End the sketch, and then extrude it in Generatrix sketch = Global and Result = One shape per profile modes. 

 

 Once the sketch is selected, extrude it to a height = (h-2*t)+20 in Alignment = Centered and Type = Solid 
modes. 
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Define the supports 

 Using the Define part function, define the two supports that were created. 

 Select the cylinder of the support as the length axis and Y+ as the width axis. 

 Adjust the following parameters: 

 Designation: Left support/Right support 
 Material: TopSolid'Wood > Metals > Aluminum 

Make the drillings 

 Start the Wood > Drilling function.  

 Set Mode = Non dynamic, and then select the upper face of the bottom shelf as the face to drill. 

 

 Select the cylinder of a support as the first alignment face or edge. 

Note: When creating a drilling, selecting an existing cylinder, circle or axis allows you to automatically orient the 
drilling with the selected element. 

 From the Drilling models window, select Hole. 

  Check the Save as default option and validate with OK. 

Note: Checking Save as default saves the drilling values for the next drilling operations. 

 Adjust the drilling's parameters: 

 Hole: Blind 
 Diameter: 20mm  
 Depth: 11mm 
 Bottom angle: 0° 

 Save the file using the disk icon. 

Note: Once the file is saved in the library, just click the disk icon to save the modifications. 
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Exercise 2: Creation of a cabinet component 

The goal of this exercise is to create the cabinet in a driver block, and then assemble it 
with dowels and cams. 

Concepts addressed: 

 Driver block 
 Propagations 
 Panels 

 
 

Creation of a driver block component 

  

 

The driver block is used to drive a component from a block. 
This makes it easier to create and use all kinds of components that can be inserted in a rectangular block: 
cabinet, back of furniture, door, shelf… 
 

Cabinet component in 
driver block 

 

Insertion of the cabinet in driver block Assembly result 
 

 
  

   
Shelf component in driver 

block 
Component insertion Result 

 

 
  

 
 

Note 
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Create the driver block 

 Create a new Design document. 

 Create the driver block using the Assembly > Define component > Define drivers > Driver block function. 

 
 Enter Name of driving element: db. 

Note: The name and designation of a driver block work the same as for a parameter. 

The name is the system name used by the parameter. It must be simple and cannot contain any spaces. The 
designation is what the user sees when using the parameter. It must be explicit and can contain spaces. 

 The lengths on X, Y and Z correspond to the default dimensions of the driver block. Leave the default 
dimensions. 

 Choose Default housing mode = Inside a block.  

 Select Current coordinate system to position the driver block.  

 Enter Designation of the driving element: Cabinet block and validate with OK. 

 
 
Note: The arrow on the driver block's face represents the front of the driver block 
and shows the top of the driver block. 
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Note: A driver block component can be inserted in six different ways: 

 Housing: 
The component is included in a cabinet housing. 
 

 

 

 Inside a block: 
The component is included inside a block. 

 

 
 
 Like a component: 

The component is included from a previously inserted driver block component. The Merge driver blocks = 
No option allows you to modify the driver block of the second component. If the option is set to Yes, the 
driver block of the second component will strictly correspond to the first one and cannot be modified 
independently. 

 

 New contour / New sketch: 
This mode allows you to draw a new contour or a new sketch, extrude it, and then include the component 
inside using the Inside a block mode. 

 

 Dimensions: The Dimensions mode allows you to insert the component in 
a more manual way by specifying the three dimensions on X, Y and Z, and 
then positioning it with constraints. 
If a catalog has been defined with the component, it is then possible to use 
it with the Dimensions mode. 
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Create the cabinet parts 

 Make layer 1 current. 

 Create a length parameter: 

 Value = 19mm 
 Name: t 
 Designation: Panel thickness 

 

 Using the constrained block, create the four parts shown opposite. 

 

 The constrained blocks have a thickness = t. 
 The constrained blocks are placed inside the driver block. 
 The left-hand and right-hand sides of the cabinet cover the top 

and the base. 
 

Note: You can use the Automatic option to create the constrained blocks more quickly.  
 

 Define the parts for the cabinet: 

 Designation: Top / Base / Left side / Right side 
 Material: TopSolid'Wood > Panels > Colors > White 

 Define the cabinet set: 

 Designation: Free-running sided cabinet 
 Assembly nature: Sub-assembly 

Save the cabinet 

 Define the t parameter as a driving parameter using the Assembly > Define component > Define drivers 
function. 

  Use Assembly > Define component > Edit/save template to save the file in the library. 

 Select Save standard template. 

 From the Save standard template window, adjust the following parameters: 

 Standard: Training library 
 New family: Cabinets 
 New type: Cabinets 
 New variant: Free-running sides 
 Uncheck Supplier code 

 Validate the window with OK. 
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Assembling the cabinet 

Create predefined propagations 

 

 In a new Design document, open Tools > Options > TopSolid'Wood configuration > Propagations 
configuration. 

 Select Add propagation to create a new propagation.  

 Then double-click on the newly created line Untitled and rename this propagation to Dowels. 

 

 From the list of propagations, modify the Right bound value on the first line to 80mm. 

 Use the Add range button to create the different ranges below.  
 

Left bound Right bound 

0mm 80mm 

80mm 200mm 

200mm 400mm 

400mm 650mm 

650mm Infinite 

 Then adjust the following propagations according to the ranges. 

 
  

 

As seen before, it is possible during assembly functions to use a certain type of propagation to configure the 
assembly. 
Predefined propagations can also be configured so that the propagation parameters do not have to be filled 
for each assembly. 
These predefined propagations also define different propagation rules according to the length to assemble. 

 
 

 

Note 



Exercise 2: Creation of a cabinet component  TopSolid'Wood Advanced 

26   Missler Software 

 Add a new propagation using the Add propagation button. 

 Rename this propagation to Cams. 

 Recreate the same ranges as for the Dowels propagation. 

 Adjust the propagations as shown below. 

 

 Validate the window with OK. 

Assemble the cabinet 

 In the free-running sided cabinet template, start the Dowel assembly function.  

 Select Wood dowel and select the D8 L30 code. Validate with OK. 

 

 Select the Filter mode and set Propagation = YES. 

 Select the face between the top and the left side as the support 
face. 

 
 

Note: When the support face of the parts to assemble is rectangular, the Automatic option can be used to 
identify the start, terminate and centered faces automatically. 

 Select Automatic.  

 The Distribution definition window opens. To use here the previously configured predefined propagations, 
select the Dowels propagation from the Propagation name drop-down list. 

 
 

 Validate the window with OK to assemble the parts. 
 
 
 
 
 
 

 Use the Copy propagation option to assemble other parts with the same 
propagation. 

 

 Repeat the previous steps to assemble the four parts with dowels 
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 Start the Cam function.  

 Select Simple cam and the L34 19 code. 
 

 Select the Filter mode and set Propagation = YES. 

 Select the contact face between the top and the left side as the 
support face. 

 

 

 Then select the bottom face of the top as the face to drill for the 
case of the cam. 

 
 

 

 Use the Automatic option. 

 From the Distribution definition window, choose the Cams propagation 
as the predefined propagation, and then validate with OK. 

 
 

 Then use the Copy propagation option to position the other three 
assemblies. 

 Save the cabinet. 
 
 
 

Creation of panels 

 
 
 
 
 
 
 
 
 

  

 
Creating panels allows edges and laminates to be placed on parts. 
Several elements are then generated: 

 A panel entity which includes the part, edges and laminates. 
 A support that is the part on which edges and laminates are placed. 
 Edges and laminates. 

 
It is then possible to use the panel entity or the support, depending on the manufacturing processes. For 
example, for the machining, if the part is machined before the edges are placed, the support will be used. But 
if the part is machined after the edges are placed, the panel entity will be used. 

 
 
                     Panel entity                    Support  -  Edges  -  Laminates 

Note 
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 From the Wood context, start the Panel function.  

 Open the panel's advanced options.  

 Adjust the following parameters: 

 Same characteristics for panel and support. 
This option automatically applies the same characteristics (designation, 
reference…) to the support and the panel entity. This means the part 
definition is done only once. 
 

 Simplified representation. 
The simplified representation is used to only view the edge textures and 
laminates without displaying them in 3D. 
 
Note: For design purposes, it is strongly recommended that you always 
work in simplified representation when designing. This improves overall 
graphics performance during the design. 
The detailed representation mode is used for example in a draft to view 
the real edges. 
 
 
 
 

 

 

 

 

 

 Assembly nature: Sub-assembly. 

The Sub-assembly mode for panels displays the edges and laminates on additional 
lines in a bill of material. 

 Design for edges: Finished. 
 Do not make laminates. 

 Validate the parameters with OK. 

 Select the main face of the left side as the reference face. 

The panel configuration window opens. 
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 Double-click in the Edge type - code box on the first line to select an edge: 

 Standard: TopSolid'Wood 
 Type: Thin edge 
 Variant: Flat edge 
 Version: 01 
 Code: ep 2 
 Material: PVC u 
 Coating: Oak 
 Codification: EDG-TH-2-PVC-OAK 

 
 
 
 
 
 
 

 Select Add to create the new edge codification, and then click on OK to validate the edge. 
 
Note: Edge codifications are used to provide the manufacturing reference of edges for the bill of material.  
It is possible to use edges without codifying them by unchecking the All edges and laminates must have one 
codification option in Tools > Options > TopSolid'Wood Configuration > Edge/Laminate. 
 
 
 Each line corresponds to an edge of the part. By clicking on a line, the arrow 
corresponding to the selected edge turns red. 

 Uncheck the line of the rear edge in order not to place an edge on the panel's 
rear edge. 

Its arrow then turns transparent. 

 Double-click in the Beginning cut type box to set the covering long side. 

 
 

 

 Validate the window with OK to create the panel. 

 Repeat these operations to apply edges to the other three parts: 

 On the right-hand side, the rear edge is not placed. 
 On the top and the base, only the front edge is placed.  

 Save this file. 
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Supplement: Predefined values 

 

 Start the Parameter > Modify parameter function. 

 Enter Parameter to modify: t and press Enter to validate. 

 Open Advanced parameters using the  button. 

 Select Predefined values=0.  
 
The Predefined values window opens. 

 Enter the three values 16, 19 and 22. 

 Check Only those values. 

 Validate the window with OK. 
 
 
 
 
 
 
 
 
 

Note: The Only those values option allows you to enter for this parameter only the predefined values specified 
here. 
The Designation field associates a designation to the predefined values. 
 

   

 Save the file.  

Predefined values can be defined for a parameter. 
This means that, when using this parameter, it is possible to use one of the predefined values. 
This helps, for example, to set the panel thickness to certain values only. 

 

 

 

 

 

 

Note 
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Exercise 3: Creation of a grooved back component 

In a library component, it is possible to define machinings that will be performed when 
the component is inserted. 
For example, this is the case for cams and dowels which perform drillings after their 
insertion. 
This process will be used in the grooved back cabinet component which will automatically 
perform the grooves once inserted. 

Concepts addressed: 

 Negative shifts on constrained blocks 
 Martyr parts 
 Component processes 

 

Creation of the component 

Create the driver block 

 Create a new Design document. 

 Create the driver block via Assembly > Define component > Define drivers > Driver block: 

 

 Name of driving element: db 
 Leave the default dimensions 
 Default housing mode = Housing 
 Select Current coordinate system to position the driver block on the current 

coordinate system. 

 

 Designation of the driving element: Cabinet block 

 
 
 

Create the back 

  Make layer 1 current. 

 Use the Constrained block function to create the back:  

 Thickness = 8mm 
 Shift = -5mm on the four selected faces 
 Selected planes: Four sides of the driver block 
 Positioning shift: -10mm 
 Positioning plane: Rear face of the driver block 
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Define the part 

 Define the back using the Define part function: 

 Designation: Grooved back 
 Material: TopSolid'Wood > Panels > Colors > White 

 
Note: An assembly containing one part is automatically defined in Single unit mode. The part information is 
automatically included in the assembly in a bill of material. 
All information must then be specified on the part. 

 Save the component in the library using Assembly > Define component > Edit/save template > Save standard 
template: 

 Standard: Training library 
 Family: Cabinets 
 New type: Backs 
 New variant: Grooved back 

Creation of processes 

Create the martyr parts 

Note: The goal of creating the Grooved back component is that it can perform its grooves automatically when 
inserted in a cabinet. To do this, the grooves must be created in the component on "martyr" parts: these parts 
will be created without being defined so that they are not included with the component. 

 Make layer 2 current. 

 Change the design color to differentiate between martyr parts.  

 Use the Constrained block function to automatically create the four martyr 
parts on the driver block's sides: 

 Thickness = 19mm 
 Selected planes: Four sides of the driver block 
 Positioning: Outside the driver block 

 
 
 
 
Note: The martyr parts of a component must not be panel entities. 
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Create the grooves 

 Turn off layers 0 and 1. 

 Start the Groove function.  

 Set Sweep = Planar face and select the inner face of the base martyr part as 
the reference face. 

 Then select the rear edge (Y+) of the martyr part as the reference edge or 
curve for tool path. 

 The groove offset shown by the red arrow must point towards the inside of the 
part. If needed, click the arrow to invert it. 

 Validate the groove path with Stop. 
 

 
 
 
 

 
 

 Adjust the groove's parameters: 

 Tool type: Routers 
 Standard: Simple mill 
 Entry/Exit: Radius 
 Distance to start point/from terminate point: -6mm 
 Parameters: High arm 
 Gap distance: 10mm 
 Groove width: 8mm 
 Groove depth: 6mm 

 

 

 

Note: The distance to start point/from terminate point of -6mm is used to extend the groove by 6mm towards 
the outside of the part to match the extension of the back with a shift of 1mm. 

 

 Validate the window with OK to create the groove. 

 Use Copy operation to perform the same groove on the other three martyr parts.  
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Define grooves as component processes 

Note: Defining the grooves as component processes (also called component tools) allows these machinings to be 
performed when inserting the component. 
A tool must be defined for each machined martyr part. Here, four tools must be created. 

 Start the Assembly > Define component > Define tools function.  

 Set Operation type = Local operation on shapes. 

Note: A local operation on shapes corresponds to a performed machining. 

 Enter Name of tool element: tool1 and validate by pressing Enter. 

 

 Change the designation to Bottom groove and validate by pressing Enter. 

 
 

 In Local operation to insert in tool, select the groove that was created on the 
bottom martyr part. 

Note: To select a machining, simply select a geometry produced by the machining: 
side edge, back face… 
If a geometry belongs to several machinings, it is possible to select the machining to 
be inserted. 
 

 Validate the default local operation name. 

 

Note: The operations selected during the creation of a tool are shown in red. 

 Validate the tool with Stop.  

 Validate the Operation as tool definition window without changing anything. 
 

 Repeat the procedure to create the other three tools: 

 Name of tool element: tool2 - Designation of the tool element: Right groove 
 Name of tool element: tool3 - Designation of the tool element: Top groove 
 Name of tool element: tool4 - Designation of the tool element: Bottom groove 

 

 Make layer 1 current and turn off layers 0 and 2. 

 Save and close the document. 
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Exercise 4: Use of components in an interior design 

The goal of this exercise is to create an interior design, and then insert the standard components that you 
previously created. 

Concepts addressed: 

 Importing a DWG file 
 Use of layers 
 Creation of the room to fit out in 3D from 2D 
 Insertion of standard components 

 
 
 
 
 

Importing and using a DWG file 

Import the file 

Importing a file in another format can be done directly using the Open function of TopSolid. 

 Start File > Open and click the Missler.DWG file.  

 Still from the Open File window, set Open as: TopSolid'Design - Design. 

 

Note: It is possible to configure how to open a DMG file using the Configure button.  

 Then in the dialog bar set the file's import parameters: 

 

 Unit: Used to set the unit to use for this document (m, mm, km…). 
Select Unit = Automatic to automatically detect the unit of the document. 

 Standard: Used to set the type of drawing standard to use for this file (Iso, Ansi…). 
Select Standard = Automatic to automatically detect the standard of the document. 

 Validate the parameters and then the Import Options window. 

 

Note: When imported, a file is automatically converted to the TopSolid format (.top) in a new document. 

 Save this document in a folder named Interior design and rename it Interior design. 

 Answer No to the Part definition window. 
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Explore the imported file 

Note: When a DXF or DWG file is imported in TopSolid, the drawing colors are automatically retrieved. 
In addition, the overlays are imported on the TopSolid layers. The names of these overlays are also imported via 
the names of the layers. 
 

 Open the construction tree using Ctrl + ². 

 Click the Layers tab. 
 

Note: The Layers tab of the construction tree displays the different layers of the 
document. 
 
Right-clicking on a layer allows you to make it current or active, give it a name or 
add elements. 

 
 
 

By default, only the non-empty layers are displayed. 

 Right-click > Definition on the first Non empty layers line and adjust the following parameters: 

 Display = All layers 
 Sort = Numerical and validate with OK 

 
 

Create the walls 

 Make layer 9 current and name it Walls. 

 Turn off layer 5 by double-clicking on it. 

 From the Shape context, select Extruded.  

 Set New contour = Sketch and select New contour. 

 

 Then select Rectangular. 

 

 Select the bottom left-hand corner of the lounge as the first diagonal point. 

 

 Select the intersection point between the exterior wall (light blue) and the interior wall (black) as the second 
diagonal point. 
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 Extrude this wall in the Z+ direction to a height: 2500mm. 

 Repeat this operation to extrude a second wall perpendicular to the first one to the double door (purple). 
 

 

 Create several walls of the house in the same way. 

 

Create the columns 

 Follow the same method to extrude the three columns of the lounge. 
 
 
 
 
 

Create the floor 

 Make layer 10 current and name it Ground. 

 Follow the same method to extrude the floor on the whole plane in the Z- direction to a height: 100mm. 
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Use of standard components 

Draw the construction volumes 

 Make layer 11 current and name it Construction volumes. 

 Turn off layers 0 to 8. 

 Create a new sketch. 

 Use the Contour > Rectangular function to draw any rectangle.  

 

 Next click the Auto dimension button to automatically place the rectangle's dimensions. 

 

 The next dialog allows you to place symmetry constraints on dimensions. Click on OK. 

 Repeat the operation to draw four other rectangles as shown below. 

 

 Use Modify parameter to adjust the rectangle dimensions to the following values: 

 X=2000 ; Y=650 
 X=1500 ; Y=650 
 X=750 ; Y=500 
 X=750 ; Y=500 
 X=700 ; Y=500 

 Then place an alignment constraint between the lower segments of the rectangles and the inner edge of the 
low wall. 
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 Place a dimension between the rectangle of 2000mm and the right-hand column to a value: 1000mm. 

 Place alignment constraints between the rectangles to obtain the following result. 

 

 End the sketch. 

Extrude the construction volumes 

 Change the design color to cyan. 

 From the Shape context, select Extruded. 

 Set Generatrix sketch = Global and Result = One shape per profile. 

 

Note: The Generatrix sketch = Global mode extrudes the whole sketch in one go. 
The Result = One shape per profile mode allows you to obtain a distinct shape per drawn contour. 

 Next select the sketch. 

 From the advanced parameters >>, set Offset from starting curve = 100mm, and then validate with OK.  

  

 Extrude the blocks in the Z+ direction to a height: 450mm. 

 Using the Attribute > Transparency function, apply a transparency of 7 to the extruded blocks. 

 

Modify the construction volumes 

 Open the construction tree using Ctrl + ². 

 From the Main tab, right-click > Edit. 

Note: The Edit function allows you to modify an element in the construction tree. This makes it easier to find all 
the elements and parameters used by this element. 
 

 Select the left-hand construction volume as the element to edit. 

 

The extruded block is now open in the construction tree. 
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 Click on + to develop Extruded shape on curves. 

All the elements that were used to create the extruded shape are shown here: 

 The generatrix: This is the sketch used for the 
extrusion. 

 The absolute coordinate system: This is the 
coordinate system which allowed the definition of 
the extrusion direction. 

 The extrusion length. 
 The offset from starting curve. 

 
Note: All the construction volumes have been extruded in a single operation. This means that the extrusion 
lengths and the offsets from starting curves are merged between the blocks. 
To modify a volume without changing the others, the parameter must be replaced. 

Note: It is also possible to modify an extruded shape locally without changing the others using the Modify 

element function.  

 Right-click on Offset from starting curve and select Replace. 

 Set Replacement = Local and Replacement parameter = 800. 

 Also replace the extrusion length by 1200. 
 

 

 Edit the two identical right-hand blocks: 

 Replace their extrusion length by 700mm. 
 Replace their offset from starting curve by 1300mm. 
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Include standard components 

 Make layer 12 current and name it Cabinets. 

 To include standard library components, use the Include standard function from the Assembly context.  

 From the Standard component inclusion window: 

 Select Training library in the drop-down list. 
 Select Cabinets > Cabinets > Free-running sides. 
 Validate with OK. 

 
 
The Cabinet component is a Driver block component. When including this component, you will be asked to select 
the destination volume of the Driver block. 

 Set Housing mode = Inside a block and Hide block = No. 

 

Note: The Housing mode = Inside a block mode has been set by default in the Driver block component to avoid 
setting it during its insertion. It is therefore possible to modify its inclusion mode. 
The Hide block option automatically hides the construction volume used. 
 

 Select the front face of one of the construction volumes as the cabinet block. 

The Driver block is automatically included in the construction volume. 
 
Note: The red arrows on the six faces of the block allow you, for each 
support plane, to: 

 modify the plane; 
 add an offset or a length to the plane; 
 define a passing point for the plane. 

In addition, two curved arrows on the front face allow you to rotate the 
driver block around the Z axis. 

 Set Multiple inclusion = YES to include the same Driver block component several times. 

 Select the front faces of the other four construction volumes, and then validate with OK. 
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 Set Thickness of panels = 19mm and 
validate with OK. 

 Turn off layer 11 to hide the construction 
volumes. 

 
 
 
 
 
 
 
 

Modify a driver block component 

 Start the Modify element function and select the bottom left cabinet. 

 Select Driver block = Cabinet block in 
order to modify the driver block of the 
cabinet. 

 
 Select the up arrow of the component to 

modify the top support plane. 
 
 
 
 
 
 
 

 Select the Shift option.  

 Enter Shift = 150mm and validate with OK. 

 

 Validate the changes made to the driver block with OK. 
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Adjust the display mode 

Note: By default, the components of a standard library are inserted in detailed representation. 
As it is not recommended to work in this representation, you need to change the representation mode of the 
inserted elements. 
 
Note: To insert the standard components in simplified representation, select Tools > Options > 
Components > Components management > Representation: Simplified. 

 

 Open the construction tree using Ctrl + ². 

 From the Main set tab, right-click the ASSEMBLY line 
and select Representation. 

 Set Representation = Simplified. 
 
Note: The Representation = Mixed mode means that some elements are in simplified representation and others 
in detailed representation. 

Include the grooved backs  

 Use the Include standard function to include the standard component Grooved back.  

 Set Housing mode = Housing. 

Note: To insert a Driver block component in housing mode like inside a cabinet, 
simply select one of the four inner faces of the cabinet. 

 
 
 

 Select one of the inner faces of a cabinet as the cabinet block. 

The driver block is automatically included in the inner volume of the cabinet. 

 Set Multiple inclusion = YES and position the driver block in the other four cabinets. 

 

 Validate the driver blocks with OK. 

 Then create the processes of the Back component using the Automatic function. 

  
 
Note: To create the processes of a component after including it, use the Assembly > Use process function and 
select the component with the processes. 
The automatic processes are only created on defined parts. 
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Include the shelf 

 Use the Include standard function to include the Wall shelf component.  

 Adjust the parameters for the shelf: 

 Shelf length = 1500mm 
 Shelf depth = 300mm 
 Shelf height = 250mm 
 Panel thickness = 19mm 

 

The Wall shelf component is calculated, and then inserted based on the parameter values you entered. 

 Left-click in the space to release the component. 

 Then place three constraints on this component to position it: 

 Rear edge of the shelf/Wall, Distance = 0mm 
 Base of the shelf/Top of the bottom right-hand cabinet, Distance = 250mm 
 Left-hand side of the shelf/Left-hand side of the bottom right-hand cabinet, Distance = 0mm 

 

 

Define the set 

 Define the set using Wood > Define > Define set > Characteristics: 

 Designation: Lounge fitting. 
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Exercise 5: Creation of a counter with geometric drivers 

The goal of this exercise is to create a "Counter" component 
driven by a path, and then insert it in the interior design. 

Concepts addressed: 

 Component driven by a path or component with 
geometric drivers 

 Pipe shape 
 Trim by planes 
 Unbent parts 

 
 

Creation of a component with geometric drivers 

Create the driving path 

 Create a new Design document. 

 Change the design color to blue (12). 

 Start the Curve > Circle function, and then draw a circle arc in Passage point mode. 

  
 
Note: The circle arc must be rather large to facilitate the design. 
 

 
  

 

The component driven by a path or component with geometric drivers is used to create a component which 
will take the desired shape when inserted in an assembly. 
 
Here, the Counter component is designed according to the blue driving path. 
This means that any line or circle arc can be defined as a driving path when inserting the component. The 
component will take the desired shape. 
Below are two examples that show the insertion of the left-hand component on a line and a circle arc. 
 

 
 

 

Note 
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 Start the Edit > Break associativity function. 
 
Note: Breaking the associativity of an element breaks the links it has with its construction elements. It therefore 
becomes completely independent. 
This operation must be performed on the component's driving path to avoid any errors when assembling. 
Moreover, a sketch cannot be basified. That is the reason why the driving path was created from a curve. 

 Select the circle arc in Elements to break their associativity. 

The circle arc then becomes completely independent. 

 Start the Edit > Name function and select the circle arc. 

 Enter Name: t and Designation: Trajectory. 

  
 
Note: Naming an element makes it easier to find it in the design. 

 Make layer 1 current. 

 Start the Tools > Coordinate system function.  

 Set Wizard = YES. 

  

Note: Several types of coordinate systems are available in TopSolid in order for you to create the most 
appropriate one for the current design. These coordinate systems can be found in Tools > Coordinate system. 

The coordinate system wizard allows you, by selecting several elements, to automatically select the appropriate 
type of coordinate system, and then create it. 

Here, a coordinate system on curve and point will be created in order to be positioned perpendicular to the curve 
path and at the end of this path. 

 First select the circle arc, and then select the right end of the circle arc as the point. 

 Select Set as current to be positioned along this coordinate system. 
 

Create other parameters 

 Using the Parameter > Create function, create the parameters shown 
opposite in Unit type = Length mode. 

 
 

 Open the list of parameters using Parameter > Edit list. 

 Define the parameters as drivers by changing the Driver column's value from No to Yes. 

Define the path as driver 

 Start the Assembly > Define component > Define drivers function. 

 Enter Driving element to insert: t and press Enter to validate. 

 Confirm the default designation of the driving element. 

The t path is now a driver of the component. 
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Save the component 

 Save the component in the library: Assembly > Define component > Edit/save template > Save standard 
template. 

 Adjust the following parameters: 

 Standard: Training library 
 Family: Furniture 
 New type: Counter 
 New variant: Interior counter 

 Validate the window with OK. 

Drawing the parts 

Draw the bent front 

 Turn off layer 0 and set the design color to black. 

 Start a new sketch on the current coordinate system. 

 Draw a rectangular contour on the left of the coordinate system, and then dimension it 
automatically using the Auto dimension button. 

 Delete the height dimension of the rectangle.  

 Use Modify parameter to modify the width of the rectangle to 10mm. 

 

 Then dimension:  

 from the top of the rectangle to the X axis with a nominal value = h; 
 from the bottom of the rectangle to the X axis with a nominal value = 70mm; 
 from the right-hand side of the rectangle to the Y axis with a nominal value = td. 

 End the sketch. 
 
 

Draw the tops and baseboards 

 Make layer 2 current. 

 Draw four rectangular contours as shown opposite. Use Auto 
dimension to place the dimensions automatically. 

 Use Modify parameter to modify the rectangle dimensions to 
the dimensions shown opposite. 
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 Next apply: 

 an alignment constraint between the bottom of the baseboards (rectangles 100x10) and the X axis; 
 an alignment constraint between the bottom of the base (rectangle 200x19) and the top of a baseboard; 
 an alignment constraint between the right-hand side of the base and the left-hand side of the bent front; 
 a coincidence constraint between the top right-hand point of the top and the top left-hand point of the 

bent front. 

 Then dimension the shift of the baseboards in relation to the base to 30mm. 

 
Draw the side 

 Make layer 3 current. 

 In a new sketch, draw a four-segment contour. 

 Apply: 

 a coincidence constraint between the two upper points and the two lower points of the top; 
 a coincidence constraint between the bottom right point and the bottom left point of the bent front; 
 an orientation constraint of the lower segment along X; 
 a coincidence constraint between the left segment and the bottom left point of the base. 

 End the sketch. 
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Draw the shelf 

 Make layer 4 current. 

 Start a new sketch and draw a rectangular contour. 

 Dimension the height of this rectangle to 19mm. 

 Place an alignment constraint of the right side of the rectangle on the 
left side of the bent front. 

 Dimension the distance between the bottom of the shelf and the top of 
the base. Enter Nominal value = sh. 

 Place a coincidence constraint of the bottom left point of the rectangle 
on the left segment of the side. 

 End the sketch. 
 
 
 
 
 
 
 
 
 

Creation of parts 

Configure the current material and coating 

Note: It is possible to define a current material, a current coating and a current finishing which will be used by the 
new extruded shapes 
When creating a number of parts with the same material and coating, this avoids you to set the material and 
coating for each part. 

 In the status bar at the bottom of the graphics area, click the Mat = … button. 

 
 
Note: This box shows the default material. 
If the Mat = … button is not displayed, right-click on the status bar and select Material and coating in the list. This 
list displays all the information that can be shown in the status bar. 

 

 Once you clicked on the button, set the current material and coating: 

 Current material: TopSolid'Wood > Panels > Colors > White 
 Current coating: No coating 

 Validate with OK. 
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Curve the low parts 

Note: The pipe shape can be used to extrude a 2D (Section curve) along a path (Guide curve). 

 Start the Shape > Pipe function.  

 Set Pipe = On curves and Follow = Subsequent operations. 

  

 Turn on layer 0, and then select the blue driving path as the guide curve. 

 Adjust the red arrow so that it goes from the sketch to the path. This arrow is used to adjust the pipe shape 
direction. 

 Set Corners type = Rounded, Curves = Visible, Generatrix sketch = Local and Type = Solid. 

  
 
Note: The Corners type = Rounded mode is used to round the pipe shape when the guide curve has a sharp 
corner. 
The Curves = Visible mode keeps the curves visible on the screen after creating the pipe shape. 
The Generatrix sketch = Local mode allows you to select only one contour when a sketch contains several 
contours. 

 In Section curves or texts, select the sketch of the base. 

 

 Repeat the procedure to create pipe shapes for the two baseboards, the shelf and the bent front. 

Note: The Curves = Invisible mode is always used by default. For this exercise, set the mode to Curves = Visible 
for every application. 
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Curve the counter top 

Note: As the top is longer than the rest of the counter, its guide curve must 
be extended to the desired length. 

 Make layer 5 current and turn off layers 0 to 3. 

 Change the design color to green (10). 

 From the Curve context, start the Copy edge function 

 Set Mode = Edge 

 Select the upper inner edge of the bent front as the edge to copy. 

 Start the Curve > Extend function, and then select the copied green 
curve of the left-hand side. 

 
 
 
 
 
Note: The Extend function modifies the length of a curve by adding or removing a distance. 

  

 Set Type = Curvature, Mode = Extend length and Length = p to set the length of the extension. 

 

 Validate with OK. 

 Turn on layer 2, and then create the pipe shape of the top by selecting the extended green curve as the guide 
curve. 
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Repeat a sketch and extrude the sides 

 Make layer 6 current and turn on layer 3 containing the sketch of the side. 

 Start the Current coordinate system function  in order to change the current coordinate system, and 

then select Absolute coordinate system as the named coordinate system.  

Note: As the absolute coordinate system is on layer 0, this layer is automatically turned on. 

 Start the Edit > Repeat function. 

 In Template elements to repeat, select the sketch 
of the side. 

 Set Propagation = On curve. 

 Select the blue driving path shown opposite as the 
curve to propagate from the start. 

 
 
 
 
 
 

 Adjust the following parameters:  

 Distribution mode = Distribute 
 Distance computing mode = Arc length  
 Transformation mode = Constraint coordinate system 

 

 Validate these parameters, and then enter Number of instances: 2. 

  

 Start the Extruded function and set Extruded shape on = Curves, Generatrix sketch = Local and Result = One 
shape per profile. 

 In Section curves or texts, select the Element detection function.  

Note: The element detection is used to select only one of the elements belonging to an assembly or a repetition. 
In this case, in order to extrude only one sketch of the repetition, the detection should be used to specify the 
sketch to be extruded. 

 Select the right-hand sketch as the element for 
detection and validate with OK. 

  

 Extrude this sketch towards the inside of the 
counter to a height = 19mm. 

 Repeat the procedure to extrude the second side. 
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Trim the parts 

Now let's trim the shelf and the base in relation to the sides. 

 Start the Shape > Trim function.  

 Set Trim = By plane. 

 In Shape(s) to trim, use the selection in order to select several shapes. 

 
 Select the shelf and the base, and then validate with OK. 

 Select the inner face of the side as the trimming plane. 

 The red arrow represents the side of the material to be removed.  
Adjust the arrow so that it shows the outside of the counter, and then 
validate with OK. 

 Set Hide tools = No and click on OK to validate. 

 Repeat the procedure to trim the parts in relation to the inner face of the 
second side. 

 
 
 

Subtract the parts 

Subtracting the sides from the baseboards allows the notches to be made. 

 Use the Shape > Subtract function.  

 In Shape(s) to modify, use the selection in order to select several 

shapes.  

 Select the two baseboards and validate with OK. 

 Set Hide tools = No. 

 In Tool shape(s) to use, use the selection, select the two sides and 

validate with OK.  

 The sides are then subtracted from the baseboards. 
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Definition of parts 

Define the planar parts 

Note: Since the counter parts are curved parts, you 
need to define the length and width axes manually 
in order to control and calculate the precise cutting-
up of parts. 
 

 

 Make layer 7 current. 

 Start the Wood > Define > Define part function.  

 Select the counter top as the part to define. 

 Set Select axis automatically = No, Bent part = No, and then validate with OK. 
 
Note: Not selecting the axes automatically will allow you to define them manually. 

 For Length axis, select Through point.  

 Select the front left point of the counter top as the through point like in the next image. 

 

 Then select the front right point of the counter top as the second through point. 

 

 Validate the direction of the default axis with OK. 

 For Width axis, select the edge of the counter top width as shown below, and then validate its default 
direction with OK. 

 
 

The cutting-up axes are placed on the part and the rectangular cut is calculated. 
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 Repeat the steps for the other two arc parts. 

 Also define the two sides by specifying the following designations. 

 
 

 For the top only, change the material to TopSolid'Wood > Hardwoods > Beech hearted. 

Define the bent parts 

Note: The baseboards and the bent front are bent parts. To calculate their precise cutting-up, parts must be 
unfolded. 
Unfolding a part also allows this part to be machined before folding. 

 

 Start the Wood > Define > Define part function, and then select the bent front of the counter. 

 Set Select axis automatically = YES and Bent part = YES, and then validate with OK. 

 

The settings for the unfolding calculation then appear. 

 Adjust the following settings: 

 Thickness = 10mm 
 Neutral fiber coefficient = 0.5 
 Layer = 8 

 

Note: The thickness corresponds to the thickness of the part to be unfolded. 
The neutral fiber coefficient corresponds to the position of the neutral fiber on the panel thickness. A value of 0.5 
means that the neutral fiber is positioned in the middle of the part to unfold. 
The layer corresponds to the layer on which you want to place the result of the unfolding. 
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 Follow tangent faces = Yes 
 Drills on reference faces = No 

 

Note: It is possible to unfold several faces of a part in one go. The Follow tangent faces option is used to 
automatically select the faces that are tangent to the selected face. 
The Drills on reference faces option applies the drillings on the reference face to the unfolding. Only the drilling 
operations will be applied to the unfolding. 

 Select the outer face of the bent front as the face to unwind. 

 Validate with OK. 
 

 
 
 
 
 
 
 
 
 
 
 

Note: To position the unfolding, an origin coordinate system, as well as a destination coordinate system must be 
selected. 
It is possible to select one of the axes automatically placed on the part corners as the origin coordinate system. 

 Select the axis at the top right of the bent front as the origin coordinate system. 

 

 Select any point to the right of the counter as the destination coordinate system to position the unfolding. 

Note: The unfolding can be moved on the point of the destination coordinate system later using the Move 

parents function.  

 

 Enter Part designation: Bent front. 

 Validate with OK. 
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 Repeat the steps to unfold the other two baseboards: 

 Designations: Baseboard 1 / 2 
 Material: TopSolid'Wood > Panels > Colors > Olive 

 

Define the set 

 Define the set via Wood > Define > Define set > Characteristics: 

 Designation: Interior counter 
 Assembly nature: Sub-assembly 

 Save the component.  
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Use of the component 

Create the destination path 

 Open the file Interior design. 

 Make layer 13 current. 

 Draw the sketch shown opposite. 

 The left-hand point of the arc is coincident with 
the left-hand wall. 

 The circle arc is perpendicular to the left-hand 
wall. 

 Then add the dimensions as shown opposite. 

 End the sketch. 
 

Insert the component 

 Use the Assembly > Include standard function.  

 Select the component Furniture > Counter > Interior counter and validate with OK. 

 Set as drivers: 

 Trajectory shift = 0mm 
 Top height = 800mm 
 Shelf height = 350mm 
 Top extension = 1000mm 
 Trajectory: Select the previously created sketch 

 
The component is automatically calculated according to the specified parameters and the selected path. 

 

Note: Depending on the direction the circle arc is drawn, the component may be calculated on the other side of 
the circle arc. 
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 To invert the path direction: 

 Delete the component.  
 Start the Curve > Origin function and select the previously created sketch as the curve to modify. 

The arrow that appears represents the curve direction. This direction is used to calculate the component. 

 

 Invert the direction of the circle arc by clicking the red arrow. Click on OK to confirm. 
 Include the component again as shown above. 

 Save the interior design file.  



Exercise 6: Creation of a door  TopSolid'Wood Advanced 

60   Missler Software 

Exercise 6: Creation of a door 

The goal of this exercise is to create a "Door" component as driver block. To 
produce this component, you must first create the moulding tool of the door, the 
hinges and the handle. 

Concepts addressed: 

 Moulding/Counter-moulding tools 
 Door as driver block 
 Use of 3D components (hinge and handle) 

 
 

Creation of a moulding tool 

Note: Creating a moulding tool allows you to create your own tools available 
in production. 

Create the profiles 

 Create a new Design document. 

 On layer 1, draw the sketch shown below: 

 

 End the sketch, and then draw the new sketch shown below. 

 

Note: In order to obtain a correct result during the machining (TopSolid'WoodCam or machining interfaces), it is 
necessary to draw the precise profile of the tool (radius, teeth, height…). However it is recommended to simplify 
the tool path to optimize the software performance. 
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 Turn off layer 0, and then create the two offset points shown below using the Tools > Point > Offset point 

function.  

 

 Use the coordinate system wizard to create the coordinate system on the left by selecting the three points 1, 
2 and 3 shown below. 

 Repeat the procedure to create the same coordinate system on the right. 

 

 Save this file in the standard library using Assembly > Define component > Edit/save template > Save 
standard template: 

 Standard: Training library 
 New family: Tools 
 New type: Moulding tools 
 New variant: Chamfer Panel moulding 

Define the tool 

 To define the tool, start the Wood > Define > Define tool function.  

 Set Mode = Moulding and select the left-hand sketch as the tool curve. 

 

 Adjust the following parameters: 

 Tool name: tool1 
 Tool designation: Chamfer panel moulding 
 Tool number: 105 

 
 
Note: The tool number is the tool number which will be used during exports for machining (TopSolid'WoodCam 
or machining exports). This field can be left blank; the number used will be the one set by default. 

 Validate the parameters with OK, and then select the left-hand coordinate system as the position coordinate 
system. 

 Enter: 

 Position name: origin 
 Position designation: Tool origin 
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 Adjust Tool radius: 45 and Cut depth: 15. 

 

The tool is now defined and can be used to create the mouldings. 

Define the counter-moulding tool 

 Start the Wood > Define > Define tool function.  

 Set Mode = Counter moulding, and then select the right-hand sketch as the tool curve. 

 

 Adjust the following parameters: 

 Tool name: tool2 
 Tool designation: Chamfer panel counter moulding 
 Tool number: 106 

 Select the right-hand coordinate system as the position coordinate system. 

 Enter: 

 Position name: origin2 
 Position designation: Tool origin 2 

 Adjust Tool radius: 45 and Cut depth: 15. 

 Save and close this file. 
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Creation of a door component 

Create the parameters 

 Create a new Design document. 

 Create a driver block using Assembly > Define component > Define drivers > 
Driver block. 

 Adjust the following parameters: 

 Name of driving element: db 
 Default housing mode = Housing 
 Select Current coordinate system 
 Designation of the driving element: Cabinet block 

 Create the following three parameters in Unit type = Length mode: 

 Value: 20; Name: cth; Designation: Crosspiece thickness 
 Value: 80; Name: cwi; Designation: Crosspiece width 
 Value: 2; Name: dg; Designation: Door gap 

 Using the Parameter > Edit list function, define these parameters as drivers. 

 

 Save this file in the library using Assembly > Define component > Edit/save template > Save standard 
template. 

 Standard: Training library 
 Family: Cabinets 
 New type: Doors 
 New variant: Glass panel door 

Create the parts 

 Make layer 1 current. 

 Start the Constrained block function.  

 Enter Thickness = cth and First shift = dg. 

 

 Select the top face of the driver block as the first plane. 

 Set Mode = Faces and enter Second shift = dg. 

 Select the bottom face of the driver block as the second plane. 

 

  Enter First shift = dg and select the left face of the driver block as the first 
plane. 

 Set Mode = Length and enter Dimension = cwi. 

 Adjust the red arrow so that the length of the constrained block is towards the 
inside of the driver block as shown opposite. 

 
 

 Select the front face of the driver block as the positioning plane.  

 Adjust the positioning yellow arrow so that the constrained block is placed 
inside the driver block. 
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 Create the other three parts as constrained blocks as shown opposite. 

 For the top crosspiece: Length = 2*cwi 
 
Note: At this time, it is normal that the parts overlap. They will subsequently be set 
to dimensions during the counter moulding operation. 

 
 
 
 
 
 

Saw the top crosspiece 

 Turn off layer 0. 

 Create a coordinate system on the top crosspiece using Tools > Coordinate system > Wizard = Yes. 

 Place the coordinate system on the front face of the top crosspiece. 

 Validate the coordinate system with a left mouse click once both displayed dimensions appear in yellow as 
shown below. 

 
Note: The yellow dimensions cannot be modified. Here, as the coordinate system is centered on the face, the 
dimensions cannot be modified. 

 

 Validate this coordinate system with OK.  

 Use the red arrow to orient the X axis of the coordinate system on the door width as shown below.  

 Set the coordinate system as current.  
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 In a new sketch, draw the following line: 

 The left point is coincident with the left edge of the crosspiece. 
 The left point is dimensioned to a distance of cwi from the upper edge. 
 The right point is coincident on the lower right corner of the crosspiece. 

 

 

 From the Wood context, use the Sawing function to saw the top crosspiece in relation to this line.  
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Create the glass panel 

 Make layer 2 current and change the design color to blue. 

 Start the Constrained block function.  

 Enter First shift = -13.5mm and Thickness = 5mm. 
 Select the lower edge of the sawn top crosspiece as the first plane. 
 Enter Second shift = -13.5mm and set Allow non parallel faces = Yes. 

 

Note: Making a constrained block by allowing non parallel faces helps you create 
triangle and trapezoidal parts as constrained blocks. 

 Select the upper edge of the bottom crosspiece as the second plane. 
 Enter First shift = -13.5 and select the left-hand edge of the right-hand jamb 

as the first plane or point. 
 Set Mode = Face and Second shift = -13.5, and then select the right-hand 

edge of the left-hand jamb as the second plane or point. 

The trapezoidal constrained block is automatically created. 
 
 

 Enter Positioning shift = 10mm and select the front face of the top crosspiece 
as the positioning plane. 

 Adjust the red arrow outwards and the yellow arrow as shown opposite. 

Note: The red arrow corresponds to the positioning shift direction. 

 Click on OK to validate the constrained block. 
 
 
 
 
 
 
 
 

Create the mouldings 

 Make layer 1 current and turn off layer 2. 

 Start the Moulding function from the Wood context.  

 Set Sweep = Planar face and select the front face of the left-hand jamb as the 
reference face. 

 Select the inside front edge of the jamb as the reference edge or curve for tool 
path. 

 The side of the tool (large red arrow) must be towards the outside of the part.  

 The machining direction (small red arrow) can be left by default. 

 Click on Stop to validate the path. 
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The Parameters window of the moulding opens. 

 Select Training library from the Standard drop-down list. 

 Select the standard Tools > Moulding tools > Chamfer panel moulding. 

 Adjust the following parameters: 

 Entry/Exit: Radius 
 Distance to start point/from terminate point: 0mm 
 Parameters: Tangent and Rounded 
 X dimension: 0mm 
 Z dimension: 0mm 
 Angle: 0° 

 Validate the window to create the moulding. 

 Then use the Copy operation function to perform the same operation on the 

other three parts.  
 
 
 
 
 
 

Create the counter-mouldings 

 Start the Counter moulding function.  

Note: The Counter moulding function is used to automatically perform the counter-moulding on parts, based on 
a moulding already done. However, the counter-moulding tool should first be created in the standard of the tool. 

 Select the left-hand jamb as the shape to modify. 

 Select the moulding of the top crosspiece as the reference 
moulding. 

 Validate the default parameters with OK to create the counter-
moulding. 

 
 

 Then perform the following counter-mouldings: 

 Shape to modify: Bottom crosspiece; Reference moulding: Left-hand jamb. 
 Shape to modify: Right-hand jamb; Reference moulding: Bottom crosspiece. 
 Shape to modify: Top crosspiece; Reference moulding: Right-hand jamb. 

 Display layer 2. 
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Define the parts 

 Using the Define part function, define the different parts of the document.  

 

 Define the materials for the jambs and crosspieces: TopSolid'Wood > Hardwoods > Beech hearted. 

 Then define the material for the glass: TopSolid'Wood > Glasses > Clear window glass. 

Define the set 

 Use the Define set function to define the set:  

 Designation: Glass panel door 
 Assembly nature: Sub-assembly 

 Save and close the Glass panel door component. 

Creation of a handle component 

 Open the provided file Line handle. 
 
Note: To design this component, refer to the TopSolid'Wood 
Basics Training Guide, Exercise 6: Supplement - Configured line 
handle. 

Save the component 

 Save this component in the training library: 

 Standard: Training library 
 New family: Hardware 
 New type: Handles 
 New variant: Line handle 

Create the martyr part 

 Make layer 1 current. 

 From the Shape context, start the Block function and adjust the following parameters:  

 X position = Centered; X length = hl+50 
 Y position = Centered; Y length = 50 
 Z position = Below; Z length = 19 

 Then position the block by selecting the coordinate system origin as the alignment point. Press Esc on the 
keyboard to exit the function. 
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Make the drillings 

 From the Wood context, start the Drilling function.  

 Set Mode = Non dynamic and select the top face of the martyr part as the face to drill. 

 

 Select the left-hand vertical cylinder of the 
handle as the first alignment face or edge. 

 Then set: 

 Hole  
 Through one 
 Diameter: 4mm 

 
 

 Perform the same drilling on the top face of the martyr part in relation to the right-hand vertical cylinder of 
the handle. 

 
 

Define the drillings as component processes 

Note: Defining the drillings as component processes allows the drillings to be performed when inserting the 
component.  

 Turn off layer 0. 

 Start the Assembly > Define component > Define tools function. 

 

 Set Operation type = Local operation on shapes. 

 Enter Name of tool element: tool1 and press Enter to confirm. 

 

 Change the designation to Handle drillings and press Enter to confirm. 

 

 In Local operation to insert in tool, select one of the previously created drillings. 

 Validate the default local operation name. 

 Select the second drilling, validate its default name, and then validate the operation selection with Stop.  

 Validate the Operation as tool definition window without changing anything. 
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Create a key point 

 

 

 Change the design color to blue. 

 Create a coordinate system on point via Tools > Coordinate system > Wizard = Yes. 

 Select the origin of the current coordinate system as the origin point in order to create a new coordinate 
system like the current coordinate system. 

 Validate the coordinate system on point with OK. 

 Start the Assembly > Define component > Define key-points function.  

 Select the coordinate system that was created before as the key point or key coordinate system to insert. 

 
 

 Enter Name of key coordinate system: cs1. 

Note: To be able to interchange two components positioned by a key point, the key points must have identical 
names. 
Here, the key point is named cs1 pour Coordinate system 1. 

 Enter Designation of key coordinate system: Handle middle. 

 
  

 

A key point is used to quickly position a component in relation to a 
coordinate system. 
This type of component positioning is often used for components such as 
hardware, which are positioned identically. 
 
The key point is defined in the component by a coordinate system. If the 
component can be positioned in many different ways, it is possible to define 
several key points. The key point to be used is then selected when positioning 
the component. 

 
 

Note 
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Create a catalog 

 

 Create the catalog using Assembly > Define component > Edit catalog header. 

 

 Then select All parameters and texts in the drop-down list to manage all 
the document parameters in the catalog. 

 
Note: The catalog of the component is automatically generated in Excel format. If Excel is installed on your 
computer, the catalog will be opened in Excel; if not, the catalog will be opened with Notepad. 
 
The first column of the $code catalog is used to enter the component code 
which will be displayed in TopSolid. 
The different parameters to configure according to the codes are on the next 
columns. 

 Fill in the columns as shown opposite. 

 Save and close the Excel file. 

 Save the Line handle component, and then close it. 

Include the handle 

 From a Design document, edit a standard component using Assembly > Define component > Edit/save 

template > Edit standard template.  

 Select the component Cabinets > Door > Glass panel door in the training library, and then validate with OK to 
open this document. 

 Make layer 3 current. 

 Include the line handle using the Assembly > Include standard function. 

 In the component inclusion window, select Code: L256. 

  

 Position the handle on the left-hand jamb. 

 Select the left-hand edge of the jamb as the first alignment edge. 

 Enter Distance = -(cwi-15)/2. 

  

 Select the lower edge of the bottom crosspiece as the second alignment edge, 
then the upper edge of the top crosspiece as the parallel face or edge in order 
to center the handle on the door height.  

 

If a component (furniture or hardware for example) is only available in certain dimensions, it is possible to 
create a catalog. 
This catalog will be used to automatically configure one or more component parameters in relation to a 
selected code. 
 

 
 

 

Note 
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 Click on Stop so that the handle is not repeated. 

 Select Automatic to automatically create the tools of the handle and drill the 
left-hand jamb. 

 
 
 
 
 
 
 
 
 
 
 

Creation of a hinge component 

 

 
 

Use the body of the hinge 

 Open the provided file Body CLIP top 75t1750.top. 

 Save this file in the training library: 

 Family: Hardware 
 New type: Hinges 
 New variant: Inserted hinge body 107° 

 Define the part: 

 Designation: Inserted hinge body 107° 
 Reference: 75t1750 
 Supplier: Blum 

 Make layer 1 current. 
 

 Define the document's absolute coordinate system as a key point via Assembly > Define component > 

Define key-points, and then select the coordinate system.  

  
  

 

 
Hardware suppliers propose to provide the 3D geometries of their hardware 
parts. 
These 3D files can be opened and used in TopSolid'Wood, but to be used 
optimally these components should be made "intelligent" by assigning 
processes and key points to them. 
 
For information, a 3D component library from the hardware manufacturer 
BLUM is available on the Installation DVD (Disc 2). 
This exercise is based on a hinge base and a hinge body from this library. 

Remarque 
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 Create the rectangular sketch that will allow the 
extrusion of the martyr part. 

 When extruding the sketch, open the advanced 

parameters.  

 Then select the hinge's bottom support face as the shift 
origin face in order to extrude the part from this face. 

 Validate the parameter with OK and extrude the part to 
19mm. 

 
 
 
 
 
 

 On the martyr part, create two blind holes aligned on the drillings 
of the hinge's screws:  

 Diameter: 5mm  
 Depth: 12mm 
 Bottom angle: 0° 

 
 
 
 

 On the martyr part, create a blind hole aligned on the hinge:  

 Diameter: 35mm  
 Depth: 12mm  
 Bottom angle: 0° 

 
 

 Define these drillings as component tools: 

 Name of tool element: tool1 
 Designation of the tool element: Door drillings 

 Insert the three created drillings in this tool. 

 Save and close the file. 
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Use the base of the hinge 

 Open the provided file Base CLIP top 174e6100_01.top. 

 Save this file in the training library: 

 Family: Hardware 
 New type: Hinges 
 New variant: Base CLIP TOP 

 Define the part: 

 Designation: Base CLIP TOP 
 Reference: 174e6100_01 
 Supplier: Blum 

 Make layer 1 current. 
 

 Define the document's absolute coordinate system as a key point via Assembly > Define component > 
Define key-points, and then select the coordinate system. 

 
 
 

 Create the martyr part from a sketch positioned on 
the support plane of the base. 

 
 
 
 
 
 
 
 

 On the martyr part, create two blind holes aligned on the drillings of the base's screws:  

 Diameter: 5mm 
 Depth: 12mm 
 Bottom angle: 0° 

 Define these drillings as component tools: 

 Name of tool element: tool1 
 Designation of the tool element: Base drillings 

 Insert the two created drillings in this tool. 
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Create the mounted hinge component 

 Create a new Design document. 

 Include the standard component Inserted hinge body 107°. 
 

 Select the absolute coordinate system of the new document as the 
destination coordinate system. 

 Repeat the same operation to assemble the base of the hinge. 
 
 
 
 
 
 

Note: In general, when assembling hardware parts provided by manufacturers, positioning the elements absolute 
coordinate system on absolute coordinate system allows them to be exactly positioned relative to each other. 

 Save the mounted hinge in the training library: 

 Family: Hardware 
 New type: Hinges 
 New variant: Inserted hinge 

 Define the part: 

 Designation: Inserted hinge 
 Supplier: Blum 

Create the key point of the hinge 

Note: As the hinge is positioned in relation to the cabinet side, the key point will be positioned in relation to the 
absolute coordinate system of the complete hinge. 

 Start the Tools > Coordinate system > Wizard = Yes function. 

 Select the absolute coordinate system. 
 
Note: When selecting a coordinate system, the wizard will create a duplicate coordinate system. 
The six red arrows allow you to create a translated coordinate system, while the advanced options allow you to 
create another transformation. 

 Select the Advanced options button.  

 Adjust the following parameters for the transformation: 

 Rotation 
 Axis: Y- 
 Rotation angle: 90° 

 Define the created coordinate system as the key point: 
Assembly > Define component > Define key-points. 

 Name of key coordinate system: cs1 
 Designation of key coordinate system: Cabinet side 

 Save and close the file.  
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Insert the hinge on the door 

 Using Assembly > Define component > Edit/save template > Edit standard template, edit the standard Glass 
panel door component. 

 Create a new parameter using the Parameter > Create function. 

 Set Unit type = No unit and select Tabulated values. 
 
Note: The Unit type = No unit mode will create a parameter that allows a quantity to vary. Here, this parameter 
will be used to vary the quantity of hinges on the door. 
A parameter with tabulated values modifies the value of a parameter according to the value of another 
parameter. Here, the number of hinges will vary depending on the door height. 
 

 Enter Reference parameter: db.z 

Note: As a reminder, the door has been designed on the basis of 
a driver block. 

This driver block has been named db, so the db.z parameter is 
the dimension of the driver block on the Z axis, i.e. the height of 
the component. 
 
The Tabulated values table opens.  

 Create the different lines by entering the reference values of 
db.z and the values as shown opposite. 

The result is the following, with the door height as reference: 

 from 0 to 650mm => 2 hinges 
 from 650 to 1100mm => 3 hinges 
 from 1100 to 1900mm => 4 hinges 
 beyond 1900mm => 5 hinges 

 Validate the window with OK. 

 Enter: 

 Name: hn 
 Designation: Number of hinges 

 
 

 Display the driver block on the layer 0. 

Note: As the hinge is positioned on the cabinet, you need to create a martyr 
part to position the hinge. 

 Using a constrained block, create the martyr part to the right of the driver 
block. Position this part outside the block as shown opposite. 
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 Turn off layer 0. 

 Insert the hinge using the Assembly > Include standard function. 

 Select the inner face on the martyr side as the destination coordinate system. 
 

 Select the lower edge on the martyr side as the first alignment face or edge. 

 Enter Distance = cwi + dg + 40. 
 

 Select the front edge on the martyr side as the second alignment face or edge. 

 Enter Distance = 38.5 + cth. 
 

 
 

 Select the Repeat option to directly repeat the hinge.   

 Select Propagation: Linear, Propagation direction: Y+. 

 Enter Total distance = db.z-(2*cwi)-(2*dg)-80 

 

 Total number: hn 

 

 Select Automatic to create the drillings of the hinges on the door.  

 Save and close this component. 
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Use of the door 

 Open the file Interior design.top. 

 From the Assembly context, use the Include standard function to 

include the door component.  

 Then include the door as driver block in the left-hand cabinet. 
 

 

 Validate the default values of the driving parameters, and then perform the machinings using the Automatic 
option. 

Note: The tool processes defined in a component are automatically inherited at each assembly level.  
Here, the tools of the base's drillings are automatically inherited, then performed on the cabinets. 
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Supplement: Declaration of the handle as a sub-component 

 

 Edit the template document of the door: Assembly > Define component > Edit/save template > Edit 
standard template. 

 Start the sub-component function: Assembly > Define component > Define sub-component.  

 Select the line handle as the component. 

 Enter Name = Handle and press Enter to confirm.  

Note: Three options are available to configure the sub-component: 

 Code: Used to modify the catalog code of the sub-component. 
 Variant: Used to interchange the sub-component with another one. 
 Allow suppression: Used to delete the sub-component. 

 Check the Code option and click on OK to validate. 

 Then click on Stop. 
 
The handle is now defined as a sub-component. It will then be possible to modify its catalog code after the door 
insertion. 

 Save and close the door component. 
 

 Open the file Interior design.top. 

 Start the Modify element function and select the door.  

 Click the Sub-component button to modify a sub-component of the door.  

 In the window that appears, expand the node of the door, click on Line handle, and then click the Interchange 
button. 

 

 Change the code of the handle and click on OK to validate. 

The handle is then modified in the assembly.  

 

It is possible to declare several elements of a component as sub-components. This allows you to make changes 
to the sub-component once the component has been included. 
In the case of the door with the handle, declaring the handle as a sub-component will allow the handle to be 
modified or interchanged with another one, once the door has been included. 
 

 

Note 
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Exercise 7: Creation of glass shelves 

The goal of this exercise is to make a "Glass shelves" component in a driver block. 

Concepts addressed: 

 Linear constraint distribution of a constrained block 
 Measured parameter 
 Multi-drilling 
 Driver propagation 

Creation of the component 

Create the parameters 

 Create a new Design document. 

 Create a driver block: 

 Name: db 
 Default housing mode: Housing 
 Designation: Cabinet block 

 Create a parameter and define it as a driver: 

 Unit type = No unit 
 Value: 3 
 Name: ns 
 Designation: Number of shelves 

Save the component 

 Save this component in the training library: 

 Family: Cabinets 
 New type: Separation panels 
 New variant: Glass shelves 

Create the shelves 

 On layer 1, create the shelves as constrained blocks: 

 Thickness = 5mm 
 Planes: Four faces of the driver block 

 When selecting the positioning plane, use the Linear constraint option. 

 
 
Note: The Linear constraint option is used to repeat the constrained block. 

 Select the bottom face of the driver block as the start face or edge. 

 Select the top face of the driver block as the terminate face or edge. 
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 From the Distribution definition window, select 
the Advanced distribution mode. 

 Adjust the following parameters: 

 Check Unitary step 
 Step (p): 32mm 
 Minimum distance to start: 130mm 
 Minimum distance to terminate: 130mm 
 Element number: ns=3 
 Check Give priority to ends 

 
Note: The Advanced mode in Unitary step is used to 
distribute a given number of elements with minimum 
start and terminate distances.  
With the 32mm unitary step, the gap between the 
elements will always be a multiple of 32mm. 
 
 
 
Checking the Give priority to ends option changes the distribution mode of the repetition instances. This is 
necessary for the rest of the exercise (measured distance parameter). 
 

Do not give priority to ends Give priority to ends 

  
 
 

 Click on OK to validate the Distribution definition window. 

 Center the constrained blocks in relation to the calculated distribution.  

Modify the repetition template 

Note: The Linear constraint option repeats the constrained block. This means that a template of the repetition is 
hidden and some instances are displayed. 

 Use the Modify element function and select one of the repeated constrained 
blocks. 

 Select the Edit template option to hide the repetition instances and display the 

template.  

 From the Shape context, use the Chamfer function to apply a chamfer with a 

length = 1mm to the bottom and top faces of the shelf.  

 Use the Edit > Repeat > Show repetition function, and then select the template of 
the shelf to display the repetition instances again and hide the template. 
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Define the shelves 

 Define the shelves: 

 Designation: Glass shelf 
 Material: TopSolid'Wood > Glasses > Clear window glass 

 Define the set: 

 Designation: Glass shelves component 
 Assembly nature: Sub-assembly 

Creation of processes 

Create the martyr parts 

 Make layer 2 current. 

 Create the martyr parts of the component by creating two automatic constrained 
blocks with a thickness = 19mm on the right-hand and left-hand sides of the 
driver block. Position the constrained blocks outside the driver block.  

 Turn off layer 0. 
 
 
 
 

Create the measured parameter 

Note: As the shelves are repeated in Advanced mode, the distance of the first shelf from the bottom 
automatically adjusts to the height and the number of elements. 
In order for the multi-drillings to automatically start from the first shelf, a measured parameter from the bottom 
of the component to the first shelf will be created. 

 Create a measured parameter.  

 Select Distance parameter.  

 Select the lower face of the martyr part as the first element. Use the Plane option to select only faces. 

 
 Then select the bottom face of the low shelf as the second element. 

 Name this parameter dps. 
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Create the multi-drillings 

 

 From the Wood context, start the Drilling function.  

 Select Define model to create a new drilling.  

 Create this drilling in Model = User mode and name this model Shelf support 5x12. 

 

 From the drilling definition window, select Hole in the left-hand list, and then move it to the right-hand list. 
Click on OK to validate. 

 Adjust the following parameters: 

 Hole: Blind 
 Diameter: 5mm 
 Depth: 12mm 
 Bottom angle: 0° 

 Validate with OK to create the new drilling model. 

 Start the Multi-drillings function.  

 Set Propagation = Double and select the inner face of one of the martyr parts as the support face. 

 

 Select: 

 the bottom edge of the martyr part as the starting face or edge for the first 
propagation. 

 the top edge of the martyr part as the terminate face or edge for the first 
propagation. 

 the front edge of the martyr part as the starting face or edge for the second 
propagation. 

 the rear edge of the martyr part as the terminate face or edge for the second 
propagation. 

 
The distribution definition window opens. 

 Select the drilling model you just created as the element to propagate. 

  

 

The Multi-drillings function is used to propagate a drilling directly on a face in one or two directions. 
Before performing the multi-drillings, a drilling model should be created. 
 

Simple propagation     Double propagation 

 
 

 

Note 
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 Adjust the parameters for the first propagation (on the height of the component): 

 Distribution mode: Step 
 Step (p): 32mm 
 Distance to start: dps - 64 
 Optimize the number of elements 

 Adjust the parameters for the second propagation (in the depth of the 
component): 

 Distribution mode: Distance 
 Distance to start (d0): 50mm 
 Distance to terminate (d1): 50mm 
 Element number: 2 

 Validate these parameters with OK to perform the multi-drillings. 

 Similarly, perform multi-drillings on the second martyr part. 

Define the multi-drillings as processes 

 Define the multi-drillings as component processes using Assembly > Define component > Define tools. 

Machining Name of tool element Designation of tool element 

Right multi-drillings tool1 Right drillings 

Left multi-drillings tool2 Left drillings 

 Save and close this component. 

Include the component 

 Open the file Interior design.top. 

 Include the Glass shelves component via Assembly > Include standard.  

 To insert a driver block component in the same cabinet as an already inserted driver block component, select 
Housing mode = Like a component. 

 Set Merge drivers = No. 

 

Note: The Merge drivers = Yes mode is used to merge the driver 
blocks of both components. It is then not possible to modify the 
second driver block without modifying the first one, and vice 
versa. 
 

 Select the door inserted in the left-hand cabinet as the 
reference component. 

 Select the front arrow of the generated driver block, and use 

the shift.  
 

 Enter Shift = 50mm and select OK to validate. 

 

 Validate the driver block with OK and adjust the Number of 
shelves parameter. 

 Perform the component processes automatically using the 
Automatic option. 

 Save the component. 
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Supplement: Shelf propagation as driver 

 

 Edit the Glass shelves component. 

 Open the construction tree using Ctrl + ². 

 From the Main tab, right-click > Edit and select the repetition of 
the shelf. 

Note: Editing a repetition in the construction tree makes it easy to find 
and modify the repetition instances, the propagation, as well as the 
repetition template. 

 

 Right-click on the Propagation line and select Define driver. 

 

 Adjust the following parameters: 

 Name of driving element: so 
 Designation of the driving element: Shelves offsets 

  

 Open the interior design document. Delete the Glass shelves component, and then reinsert it. 

Note: The driver propagations are taken into account when inserting the 
component. If the driver propagation is declared after being inserted, the 
component must be deleted, and then repositioned to be taken into account. 

 Once the component has been reinserted, use Modify element and select one 
of the glass shelves.  

 The Offset instance option is used to offset the selected shelf. 

 

Note: It is possible to set a positive or negative value as offset. The positive offset 
will be done in the propagation direction and the negative offset in the opposite 
direction. 

 Save the document. 
  

 

The linear and circular propagations, as well as the TopSolid'Wood distributions can be defined as drivers. 
This allows the position of a repetition instance to be modified after the component inclusion. 
For example, this helps avoid a collision between a hinge and another element, or adjust the position of a 
shelf. 
 
 

 

Note 
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Exercise 8: Creation of separation panel components 
The goal of this exercise is to create two components as driver blocks of 
vertical and horizontal separation panels assembled by dowels and cams. 
To create this type of component, a shelf component assembled with martyr 
parts should first be created. This component will then be included, and 
repeated in a driver block component. 

Concepts addressed: 

 Automatic assembly 

Creation of the shelf component 

Create the parts 

 Create a new Design document. 

 Create the following three parameters in Unit type = Length mode: 

 Value = 500mm; Name: w; Designation: Width. 
 Value = 200mm; Name: d; Designation: Depth. 
 Value = 19mm; Name: th; Designation: Thickness. 

 

 Define these parameters as drivers. 

 Create the sketch shown opposite. 
The dimensions are constrained on X and 
Y. 

 Extrude this sketch to a height: th. 
 
 
 

 Then draw the sketch of the martyr parts as shown opposite. 

 

 Make layer 1 current, and then extrude the martyr parts in Alignment = Centered, Generatrix sketch = Global 
and Result = One shape per profile modes to a height = 200mm. 
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 Create a panel on the shelf using the Panel function.  
 
Note: A panel can be created only on a defined part. 

 Define the shelf: 

 Designation: Fixed shelf 
 Material: TopSolid'Wood > Panels > Colors > White 

 Configure the panel: 

 Place an edge on the front face of the panel. 
 Use the codified edge EDG-TH-2-PVC-OAK. 

  

 Save the component in the training library: 

 Family: Cabinets 
 Type: Separation panel 
 New variant: Fixed unitary shelf 

Assembling the parts automatically 

Create the automatic assembly 

 

 From a Design document, open the options: Tools > Options. 

 Go to TopSolid'Wood Configuration > Automatic assembly. 

 Select Add rule to create a new automatic assembly.  

 Double-click on the Untitled line and name this automatic assembly: Dowels + Cams. 

 

 Add a Dowel component to the automatic assembly. 

 Select Wood dowel and the D8 L30 code, and then validate with OK. 
  

 

The Automatic assembly function is used to assemble several parts together automatically. This function 
associates one or more standard components with a predefined propagation per component. 
 
 
 

 

Note 
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The Wood dowel component is added to the automatic assembly. 

 Select the Dowels predefined propagation for this component. 

 Set Centered thickness. 
 

 Then add a Cam component to the automatic assembly. 

 Select Simple cam and the L34 19 code, and then validate with OK. 

 Set the Cams predefined propagation to Centered thickness. 
 

 

 

 Validate the Options window. 

Assemble the parts 

 Start the Automatic assembly function.  

The martyr parts are not defined, so they must be selected manually. 

 Select the two martyr parts and the shelf. Click on Stop to confirm the selection. 

 From the Automatic assembly window, select Rules > Dowels + Cams. 

 

 Reselect the parts manually in the graphics area and validate the window. 

 Select the front face of the shelf as the start face. 

 Click on Centred automatically to automatically center the assembly in the thickness. 

 Click on OK to validate. 

Note: In the case of a closed assembly (a cabinet for example), selecting Outside face or Inside face allows you to 
adjust the position of the cam cases automatically. 

 
The assemblies are generated.  
The green arrow represents the positioning 
direction of the assemblies in the thickness. 
The red arrow represents the positioning 
direction of the assemblies in the depth. 
 
 
 
 

 Place the cam cases downwards. 

 Validate the positionings with OK to perform the machinings. 

 Save and close the file. 
 

 Define the set:  

 Designation: Fixed shelf component 
 Assembly nature: Content 
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Creation of distributed separation panel components 

Create the Vertical separation panel component 

 Create a new Design document. 

 Create a driver block: 

 Name: db 
 X length = 1200; Y length = 500; Z length = 800 
 Default housing mode = Housing 
 Current coordinate system 
 Designation: Cabinet block 

 Create the following two parameters: 

 Unit type = No unit; Value = 2; Name: ns and Designation: Number of separation panels 
 Unit type = Length; Value = 19; Name: th and Designation: Panel thickness 

 Define these parameters as drivers. 
 
To position and distribute the separation panels, the distance between 
the separation panels must be calculated beforehand. 

 Create a new parameter: 

 Unit type: Length 
 Value = (db.x-(ns*th))/(ns+1) 
 Name: ds 
 Designation: Distance between separation panels 

 Save the component in the training library: 

 Family: Cabinets 
 Type: Separation panel 
 New variant: Distributed vertical separation panels 

Include the component 

 Include the Fixed unitary shelf component. 

 Select for the parameter Width = db.z/Z length of db. 

 

 Select for the parameter Depth = db.y/Y length of db. 

 

 Select for the parameter Thickness = th/Panel thickness. 

Note: The two parameters of the components have the same name; it is then possible to connect them 
automatically using the Automatic -> Panel thickness = 19.000mm option. 
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 Click in the document to release the component. 

 Apply two constraints of the shelf on the driver block: 

 Origin: Front edge of the shelf; Destination: Front face 
of the driver block 

 Origin: Lower edge of the shelf; Destination: Lower 
face of the driver block 

Note: These two constraints must be set to Type = Alignment. 

 
 

 Then apply a third constraint: 

 Origin: Left-hand face of the shelf 
 Destination: Left-hand face of the driver block 
 Type = Alignment  
 Distance = ds 

  

 Select Stop to stop placing constraints. 

 Select Propagation: Linear, Propagation direction: X+. 

 Then enter Distance per instance = ds+th. 

  

 Finally, enter Total number = ns. 

 Click on Stop. 
 

 Define the set: 

 Designation: Vertical separation panel component 
 Assembly nature: Sub-assembly 

 Save and close the document. 
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Create the Horizontal separation panel component 

Using the same method as for the vertical separation panels, create a Horizontal separation panels component. 

 In a new document, create a driver block. 

 Create the two driving parameters: Number of separation panels and Panel thickness. 

 Create the distance parameter between the separation panels: Value = (db.z-(ns*th))/(ns+1). 

 Include the Fixed unitary shelf component and adjust the parameters. 

 Apply the constraints of the shelf to the driver block. 

 Propagate the separation panel linearly. 

 Define the set: 

 Designation: Horizontal separation panel component 
 Assembly nature: Sub-assembly 

 Save this component in the training library: 

 Family: Cabinets 
 Type: Separation panel 
 New variant: Distributed horizontal separation panels 

 

Using the separation panels 

 Open the interior design file. 

 Insert the Distributed vertical separation 
panels standard component in the two 
bottom cabinets. 

 Enter Number of separation panels = 2. 

 Perform the machinings using the 
Automatic option. 

 
 
 
 
 
 
 

 Then insert the Distributed horizontal 
separation panels component in the middle 
compartment of the right-hand cabinet, as 
well as in the left-hand and right-hand 
compartments of the left-hand cabinet. 

 Enter Number of separation panels = 1. 

 Perform the machinings using the 
Automatic option. 
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Note: A Driver block component can also be inserted outside a cabinet or a closed housing. If an open volume 
forms a rectangular parallelepiped, you can insert a driver block component in it. 

 Insert the Distributed horizontal separation 
panels component. 

 Select the outer right-hand face of the 
upper-mid cabinet as the cabinet block to 
place the separation panels between the 
upper-mid and the upper left cabinets. 

 
 
 
 
 
 
 
 
 

 Set Offset = 50mm on the front plane 
arrow. 

 Set 2 separation panels, and then click OK to 
validate. 

 Perform the machinings using the 
Automatic option. 

 Save the document.  
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Exercise 9: Creation of a coffee table 

The goal of this exercise is to create a coffee table 
using the constrained block and the automatic 
assembly. 
 
 
 
 

Creation of the table 

Create the construction volume 

 Create the following three length parameters: 

 Value: 1000; Name: w; Designation: Table width 
 Value: 450; Name: h; Designation: Table height 
 Value: 19; Name: th; Designation: Panel thickness 

 

 Define these parameters as drivers. 

 Create a construction volume using the Block function: 

 X length = w 
 Y length = w 
 Z length = h 
 Alignment point: Origin of the absolute coordinate system 

 Apply a transparency of 7 to this block.  

Create a second construction volume 

Note: The goal is to create a second construction volume in order 
to make the base of the table. 

 Start a new sketch.  

 Create a rectangular contour: 

 Dimension the width and height of the contour to a 
nominal value = w/3. 

 Dimension this contour to a nominal value = 100mm from 
the bottom and the right-hand side of the construction 
volume.  

 End the sketch. 
 
 
 

 Extrude this sketch: 

 Enter Offset from starting curve = -h/2. 
 Select the Z+ direction. 
 Enter Height = h-10. 

 Apply a transparency of 4 to this block. 
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Create the parts 

 Adjust: 

 The current material to TopSolid'Wood > Panels > Colors > White. 
 The current coating to No coating. 

 Make layer 1 current. 

 Create an automatic constrained block on the top face with a thickness = 10mm. 

 Position this constrained block inside the construction volume. 

 Create the four parts of the base as constrained blocks from 
the second construction volume as shown opposite: 

 Thickness = th 
 Two covering sides and two covered sides 

 Turn off layer 0. 

 Create the other two parts making up the base as constrained 
blocks: 

 Thickness = th 
 First shift = 100mm 
 Positioning shift = w/6 

 Start the Shape > Chamfer function.  

 Enter Length = 2mm and select Shape.  

 Select the glass table top to apply a chamfer onto all the 
shape's edges. 

 Validate the chamfers with Compute chamfer(s). 

 
 

Saving and defining the table 

Define the parts 

 Define the parts of the base: 

 Designation: Base 1-6 
 Material: TopSolid'Wood > Panels > Colors > White 

 Define the table top: 

 Designation: Glass table top 
 Material: TopSolid'Wood > Glasses > Clear window glass 

 Define the set: 

 Designation: Rectangular coffee table 
 Assembly nature: Sub-assembly 
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Save in the library 

 Save this component in the library using Assembly > Define component > Edit/save template > Save 
standard template: 

 Standard: Training library 
 Family: Furniture 
 New type: Tables 
 New variant: Rectangular coffee table 

Assembling the table 

 Start the Automatic assembly function.  

 Select Main assembly. 

Note: In the TopSolid'Wood selection windows, including the one for the automatic assembly, parts can be 
selected following different criteria. 

 Enable the Select by criterions option. 

 Then check the Material box and select White. Thus, all the white parts are selected. 
 

 
 
 
 

 Validate the selection with OK. 

 Select: 

 The lower edge of one of the selected parts as the start face 
 Centred automatically 
 Inside face 

 Using the green arrows, adjust the position of the cam cases as shown below, then validate with OK to place 
the hardware parts and perform the machining operations. 

 

 Save and close this file. 
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Insertion of the table 

 Open the interior design file and insert this table on layer 15. 

 Place a constraint between the bottom of the table and the floor. 

 Press the Esc key to exit the function. 
 
Note: As long as a component is not fully constrained, it can be moved and/or rotated using the Edit > Move 
parents and Rotate parents functions. 

 Start the Edit > Move parents function. 

 Select the inserted table as the element to move. 

 Position the table in the interior design, and then left-click to validate the positioning. 

 Start the Edit > Rotate parents function. 

 Select Mode = Auto. 

 Select the top face of the table as the element to rotate. 

 Rotate the table, and then left-click to validate the positioning. 
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Exercise 10: Creation of an extruded component 
 

Creation of the extruded component 

Create the coordinate systems 

 Create a new Design document by selecting Without template. 

 Make layer 1 current. 

 Create a new coordinate system using Tools > Coordinate system 
> Wizard = Yes, and then click any point to the right of the 
absolute coordinate system. 

 Validate the coordinate system on point with OK. 

 Then select Set as current. 

Note: To create an extruded component, it is necessary not to work 
on the absolute coordinate system, that's why a new coordinate 
system is created and set as current. 

 

 Start the Edit > Name function and name this new coordinate system fr1.  

 Leave the Designation field blank, and click on OK to confirm. 

 

 Turn off layer 0. 

 Create a length parameter with a value = 100mm, a name: l and a designation: Length. 
 

 Create a coordinate system using Tools > Coordinate system > Wizard = Yes. 

 Select the fr1 coordinate system in order to create a duplicated coordinate system. 

 Select the red arrow in the Z+ direction in order to duplicate the coordinate 
system along a translation in the Z+ direction. 

 Enter Distance: l. 

 Name this coordinate system fr2. 

  
  

 

Creating an extruded component enables you to easily use linear components such as baseboards, angles or 
cover profiles. 
It will then be possible to place this component directly between two points or on a whole contour, and 
perform the cuts between the different extruded components automatically (mitre cuts, covering/covered 
cuts). 
 
 
 
 
 
 
 
 
 
An extruded component must be created according to the procedure described below. 

 

Note 
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Create the profile 

 Create two length parameters: 

 Value: 100; Name: h; Designation: Baseboard height 
 Value: 15; Nom: th; Designation: Baseboard thickness 

 Create the sketch for the baseboard as shown opposite:  

 The thickness and height dimensions are constrained in symmetry on the 
X and Y axes. 

 The three fillets have a radius of 3mm. 

 End the sketch. 

 Extrude the sketch to a height = l. 
 
 
 
 
 
 
 
 
 
 
 

Create the key points 
 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

 

 

Note 

Creating several key points (shown in blue opposite) allows the 
extruded component to be positioned in different ways in relation 
to the selected path (shown in blue below). 
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 Start the Tools > Point > Offset point function.  

 Select the point shown opposite as the origin point. 

Note: The key points must be on the plane of the fr1 coordinate system. 

 Select the Y- direction and enter Distance: h/4. 

 Position the dimension to finish creating the offset point. 

The creation function automatically returns to the beginning. 

 Select the offset point created previously as the origin point. 

 Select the X- direction and enter Distance: th. 

 Position the dimension. 
 
 
 

 Use Assembly > Define component > Define key-points. 

 Select the left-hand offset point as the key point or key coordinate system to 
insert. 

 Enter: 

 Name: p1.  

 Designation: Bottom left point.  

Note: To be able to interchange two extruded components, the key points must 
have identical names. 
Here, the key point is named p1 for Point 1. 

 Then select the right-hand offset point. 

 Enter Name: p2 and Designation: Bottom right point. 

 

Define the component 

 Define the part using the Wood > Define > Define part function: 

 Designation: Baseboard type 1 
 Material: TopSolid'Wood > Panels > Colors > Olive 

 Save the component in the library using Assembly > Define component > Edit/save template > Save standard 
template: 

 Standard: Training library 
 New family: Profiles 
 New type: Baseboards 
 New variant: Type 1 

 
Note: In order to be used as an extruded component and automatically perform the cuts, this component must 
be defined as an extruded component. 

 Start the Assembly > Define component > Define extruded component function. 

 Select All assembly to define all the parts of the assembly as extruded parts. 

  

  Save and close the file. 
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Use of the extruded component 

Draw the contour 

 Open the interior design file. 

 Make layer 14 current. 

 Start a new sketch. 

 Using the Contour function, draw a contour enclosing the cabinets on the left side, the front side and the 
right side as shown below. 

 

 Start the Create offset profile function in Offset type = Profile mode to draw the offset of the curve to a 
distance = 50mm. 

  
 

 

Note: The offset curve must be inside the reference curve.  
To do this, when prompted to enter the distance, place the offset inside using the mouse, enter 50 (by default in 
the Through point box), then press Enter to validate. 

 End the sketch. 

Insert the extruded component 

 From the Wood context, start the Extruded component function.  

 From the Standard component inclusion window, select Training library and select the component Profiles > 
Baseboards > Type 1. 

 
Note: By default, an extruded component is positioned between two points. Once the extruded components have 
been generated, cuts can be performed using the Assembly > Use process function. 
The On curves option is used to automatically generate all the extruded components on a contour, and then 
perform the cuts automatically. 

 Select the On curves option.  

 Select the offset sketch in Curves. 

The three extruded components are then generated. 
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Different parameters can then be configured: 

 Key point: Used to choose the key point to position the extruded components. 
 Rotation angle: Used to rotate the extruded components. 
 Cut: Used to choose the type of cut to be applied to the components. 

 Adjust the following parameters: 

 Key point: Bottom right point 
 Rotation angle: 0° 
 Cut = Mitre cut 

  

 Click on OK to validate. 
 
Note: As the counter is included on a path, the direction of the extruded components may be reversed. To modify 
the direction of a sketch, use the Curve > Origin function, select the sketch, invert the direction of the red arrow, 
then reinsert the extruded components. 

Supplement: Creation of a catalog and addition of baseboards 

Create the catalog 

 Delete the baseboards inserted in the interior design document, and then close this document. 

 Edit the template document of the baseboard: Assembly > Define component > Edit/save template > Edit 
standard template. 

 Generate the catalog: Assembly > Define component > Edit catalog header. 

 Select All parameters and texts in the drop-down list. 

 
 
The catalog is then generated in Excel format. 

 Fill in the catalog boxes as shown opposite. 

 Delete the column of the l parameter. 

 Reopen the interior design document. 

  Reinsert the extruded components on the sketch by selecting the code: 
100x15 when selecting the standard extruded component. 

 

Add detailing baseboards 

 Start a new sketch. 

 Draw a contour on the wall around the part, as shown below. 

 

 End the sketch. 

 Using the Wood > Extruded component function, insert the baseboard with the code: 80x10. 

 Select On curves and select the previous sketch. 
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 Adjust the following parameters: 

 Key point: Bottom left point 
 Rotation angle: 0° 
 Cut = Mitre cut 

 Click on OK to confirm. 

 Start the Assembly > Use process function. 

 Select the left-hand baseboard of the cabinets as the component to use. 

 

 Select Main cut.  

 Set Offset: 0mm, Hide tools = No and select the baseboard on the wall as the tool shape to use. 

  

 The arrow must show the side of the baseboard to delete. Click on the arrow to invert. 

 Confirm with OK to perform the cut. 

 Repeat the operation to cut the right-hand baseboard of the cabinets. 
 

 

 Save the document. 
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Exercise 11: Creation of a draft template 
 
 
 
 
 
 
 
 

Creation of a draft template 

Create the file 

 Create a new Draft document.  

 Select Without template and select Paper format: A4H in the drop-
down list. 

 If necessary, delete the document's title block.  

 Using the Modify element function, modify the draft and uncheck 
the Center mark, Orientation mark, Coordinate system and 

Graduations boxes.  
 
Note: In order to be available when creating a new document, the template document must be saved in the 
template folder of the Config or Group folder. 
The Config folder corresponds to the individual configuration of the user station, while the Group folder 
corresponds to the common configuration of the different stations of the company. 
 

 Save the file in the folder C:\Missler\Group\Template. 

 Rename this file Training draft A4H. 
 

Create a title block 

 Use the Detailing > Title block function. 

 Set Width: 110mm and Height: 35mm. 

 Select Hook on border. 

 
 
It is then possible to create cells for the title block. 

 Select Cutting type = Regular cut in the drop-down list. 

 Enter Number of rows = 4 and Number of columns = 1. 

 

 Click on OK to validate and click inside the title block to cut it. 

 Reselect Cutting type = Regular cut in the drop-down list. 

 Enter Number of rows = 1 and Number of columns = 3, then click on OK to confirm. 

 In Cell to cut, select the second row from the bottom. 
  

 

In TopSolid, documents can be saved as templates. 
A new document can be created from this template, and then saved, regardless of the original 
template. 
Creating draft templates allows you to preconfigure drafts with for example a specific title block, the 
company logo, display settings… 

Note 
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 Select Cutting type = Vertical cut, and then cut the first and the third rows from the bottom as shown below. 

 
 

Note: To align a cutting line with an existing line, simply click the end point of the existing line. 

Insert text in the title block 

 Start the Insert function.  

 Select the title block as the element near insertion place. 

 Select the left-hand cell of the third row from the bottom to insert an element in. 

 In the cell, enter Element to insert or text to create: Draft name. 

 

 Press Enter to validate and select Fast choice > Center center to center the 
text on the width and height of the cell. 

 Validate with OK to position the text. 

Note: Inserting a plain text will make it possible to quickly modify this text when drafting to enter the draft name.  

 

 Then select the right-hand cell of the same row. 

 Select Scaling factor in the drop-down list.  

Note: This drop-down list contains variables that are automatically updated when using the draft document. 

 Set Fast choice > Center center and validate with OK. 

 Similarly, insert the following on the second row from the bottom: 

 Left-hand cell: Creation date 
 Middle cell: Author 
 Right-hand cell: Folio number (i/n) 

 Then insert the variable Property > Designation in the first row. 

 Validate with OK and select No element. 
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Note: Inserting a variable using the No element option allows the variable to be inserted according to the drafted 
element. The designation of the drafted element will be then automatically displayed here. 
 

 

 In the left-hand cell of the first row from the bottom, insert the name of your company. 

 Then click in the right-hand cell and select the Bitmap option.  

Note: The Bitmap option is used to insert an image in the title block. 

 Select the company logo you saved on your computer or the provided file TopSolid'Wood.jpg. 

 Uncheck the Linked to the bitmap file option and select Position in cell > Center center. 

 
 
Note: By unchecking the Linked to the bitmap file option, the image of the title block is not associated with the 
image file in Windows. This option is necessary if the draft template is used on different stations on the network 
or if the image is then deleted or moved. 

 To avoid distorting the logo, uncheck Resize with distortion. 

 Validate with OK to insert the image. 

 

Configure the draft template 

 Open the document properties.  

 In Projection parameters, check Use realistic rendering. 

 Save and close this file. 
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Use of the draft template 

Create a trimming volume 

 
 
 
 
 

 Open the interior design file. 

 Make layer 16 current and start a new sketch. 

 Using the rectangular contour, draw a rectangle that encloses the interior design as shown below. 

 

 End the sketch, then extrude it with an offset from starting curve = -100mm and to a height = 2600mm. 

 Apply a transparency of 10 to this block. 

 Start the Tools > Draft trimming volume function. 

 

 Select the extruded volume as the trimming volume for views. 

 Name this volume tv and click on OK to validate. 

 

 Save the file. 

Create the draft and the main views 

 Create a new Draft document. 

 In the advanced parameters, select the Training draft A4H draft template in the 
group templates. 

 Click on OK to validate. 

Note: A new draft file is then generated from the template. 

 Create a main view.  

 Select Assembly. 

 Select Document containing the set = Interior design in the drop-down list. 

 

When making a draft, it is possible to create a trimming volume. This allows you, when only a 
portion of the Design file has to be drafted, to trim the view by a block drawn beforehand. 

Note 
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 Adjust the view as shown opposite using the green arrows.  

 Check Shading view. 

 Set the smooth edges and the hidden lines to Hidden. 

 

Note: The setting of the smooth edges corresponds to the visualization of the edges 
between the tangent faces. 
The hidden lines are the non-visible edges in the projected view. Here, the hidden 
lines are hidden to avoid overloading the view. 
 
 

 At the bottom right of the window, select Trimming volume > Volume: 
tv in the drop-down list. 

 Validate the window with OK to calculate the view. 

 Place the view and set the scaling factor relative to drawing to 0.02. 

 To regenerate the view, select the Regenerate function and select the view.  

 Use Move parents to position the view as shown below.  
 
Note: For now, only the elements that make up the assembly have been drafted. Since the walls and the ground 
are not included in the assembly, they have not been drafted. To view them, add them manually in the view. 

 Select Window > Tile vertically. 

 Start the Insert function.  

 Select the main view in Element near insertion place. 

 To select several elements, use the selection lasso.  

 In the 3D document select the walls, the floor and the columns, then validate the selection with OK. 

 Regenerate the view. 
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 Create the full section view as follows:  

 Alignment = No 
 Set the section view upright = No 
 Hidden lines = Hidden 

 

 Modify the section view to check the Shading view option. 

 

 Save this draft document in the Interior design folder and keep the default name. 

 Use Modify element to modify the text of the title block: Draft name. 

 In Text, enter Assembly main views. 

 

Create a new drawing 

Note: It is possible to create several drawings in one document. Each drawing is called folio. 

 Use Tools > Drawing.  

 Select the existing drawing as the drawing to copy. 

 Click on OK to confirm the parameter window of the new drawing without changing anything. 

 Set Hook point = Bottom-Left and select the bottom right point of the first drawing in New position for the 
drawing. 

 

 Select the title block of the first drawing in Title blocks and tables to copy. 

 Click on Stop to finish the copy.  
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Create a perspective view 

 Open the Design file of the interior design. 

 Make layer 15 current and switch off layer 16. 

 Open the View tab  and select Visit mode.  

Note: In an interior design, the visit mode is used to visit the fitted-out room(s). Like a FPS video game, the mouse 
is used to rotate the view and the keyboard arrows allow you to move in the drawing. 

 Select any point in the room as the position of the user. 

 Select a point on the cabinets as the target point. 

The visit mode starts. 

 Using the keyboard arrows and the mouse, configure the same view as shown below. 

 Press Esc on the keyboard to stop the visit mode. 

 

Note: To go back to the perspective view, open the View tab  and select Perspective view.  

 Select Window > Tile vertically. 

 Click in the draft document to make it current. 

 Create a main view.  

 Select the copied left-hand drawing as the drawing in which to work. 

 Select Like a view and select one of the two existing views. 
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Note: The Like a view function only allows you to create a main view from elements already projected in the 
selected view. This function does not copy the properties of the view (view orientation, visibility of edges, 
trimming volume, exceptions, etc.) 

 Set the smooth edges and the hidden lines to Hidden. 

 Select Trimming volume: tv. 

 Click in the 3D or 3D coordinate system or face field, and then click in the space of the Design document to 
generate the drawing view as the 3D. 

 Validate with OK and position the view. 

 Using Modify element, modify the drawing. 

 Enter Scaling factor = 0.06. 

 Validate with OK and regenerate the view. 

 Use Move parents to position the view as shown below.  

 Modify the text Assembly main views to Perspective view. 
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Exercise 12: Creation of a BOM template 
 
 
 
 
 
 

Creation of a BOM template 

 In a Draft document, start the Bill of materials > Edit bill of material file function.  

Note: This function can also be found in a Design document in Tools > Edit bill of material file. 
Three tabs are available: 

 Standard: Contains the TopSolid default BOM templates. 
 User and Group: Contain the User and Group BOM templates. 

 Click the Group tab. 

 Select Create new bom file. 

 Enter Name of new bom file: General part BOM. 

 Click on OK to validate. 

 

Note: The Creation or modification of bom file window opens. Each row corresponds to a different column of 
BOM information. 

 Double-click in the Definition box on the first row to insert information. 

 From the Modification window, select: 

 Defined modules > TopSolid'Design 
 Defined functions > Index 

 

 

Note: The BOM functions are categorized (Defined modules). 
In addition, to find a function more easily in the list (Index for example), you can press the ‘i’ key in order to scroll 
through the functions starting with ‘i’. 

 Click on OK to validate. 

 Repeat the operation to add the Designation and Reference functions. 

 

 Then insert the Total count function. Before validating the 
function, change the title to QUANTITY. 

  

 

A BOM template is used to create bills of materials in a draft document, but also to export projects 
to Excel for example. 
Creating a template allows all relevant information to be displayed in the BOM. 

Note 
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 Insert the functions TopSolid'Design - Material and coating > Material and Coating. 

 Then insert the function TopSolid'Design - Physical properties > Part length. 

Note: By default, dimensions are in meters. The function format must be changed. 

 In the Format field, enter 01|mm. 

 01 corresponds to the desired number of decimal places. 
 To enter the | symbol, press Alt Gr + 6. 
 mm displays the dimensions in millimeters. 

 

 Validate the function and insert the Part width and Part thickness functions in the same way. 

 Then insert the function TopSolid'Wood > Four edges or laminates. 

 Change the title of this function to 4_PART_EDGES. 

Note: The Four edges or laminates function allows the four edges placed on a part to be displayed on the same 
column. 

 Finally, insert the TopSolid'Wood > Reference function again: 

 Modify the title of this function to BAR CODE. 
 Select Bar code > 128 in the list to display this column as follows: Bar code 128. 

 Click on OK to validate the BOM template. 
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Using the BOM template 

Create a new drawing 

 Open the Design document Interior design.top, then the Draft document Interior design.dft. 

 In the draft, Start the Tools > Drawing function and select a drawing of the document. 

 In the drawing modification window, select Paper format > A3V.  

 Using the hook point Bottom-Left, position this drawing to the right of the second drawing, and exit the 
function by pressing the Esc key. 

 

Create the BOM 

 Open the Bill of Material context.  

 Start the Bill of material function.  

 In the Group tab, select the General parts BOM template, and then click on OK to confirm. 

 

 Select the A3V drawing as the drawing in which to work. 

 Select Assembly to include all the elements of an assembly in the BOM.  

 Select Document containing the set = Interior design in the drop-down list. 
 

Note: A BOM can be displayed according to three depths: 

 At top level: The sets of the first level are displayed. 
 Flat BOM: The elements of the lowest levels are displayed. 
 Multi level: The sets can be unfolded in order to display the component elements. 

 Adjust the following parameters: 

 Depth = Multi level. 
 Add a line for set = No. 
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Note: A bill of material can be placed over a title block or between two points. 

 In Position of bill of material or title block, select the bottom left point of the A3V drawing's frame, and then 
the bottom right point as the second alignment point. 

 Exit the function by pressing the Esc key. 

Unfold the BOM 

 Start the Modify element function.   

 Select the bill of material. 

 Go to the Bill of material level choice tab. 
 
Note: This tab is used to modify the depth of the bill of material. In multi-level depth, the sets can be unfolded to 
display the component parts. 

 Using the + icon, unfold the Vertical separation panel component set, then the Glass panel door and Wall 
shelf sets, and then the Free-running sided cabinet set. 

 Validate the window with OK to calculate the desired BOM. 

Index elements 

 From the Bill of material context, start the Index function.  

 Set Search for 3d part: YES, One Text, Name = 1. 

  
 
Note: The Search for 3d part: YES option is used to index 3D file elements. 
The One text option displays the part index only. 
The Name = 1 option is used to set the created index number. The next indexes will be incremented, based on 
this value. 
The >> button allows you to use the advanced parameters to define the type of positioning of the balloon, as well 
as its style. 
 

 In Element to index, select an element in one of the three drawing views. 

The index is created. 

 Place the index on the drawing and click to validate. 
 
Note: As the bill of material is in multi-level, it is possible to index two different BOM elements with the same 
selection.  
For example, in the case of a free-running sided cabinet:  

 In Bill of material the Free-running sided cabinet set, as well as the Top panel are displayed. 
 When selecting the element to index, if selecting the top, it is possible to index either the free-running 

sided cabinet, or the top. 
 The Bill of material level choice opens and the element to be indexed is required. 
 Select the element to be indexed and click on OK to validate the window. 
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Exercise 13: Creation of a multi-draft 
 
 
 
 
 
 
 
 
 
 
 
 

Creation of the multi-draft template 

Create the template 

Note: To create a multi-draft, a specific draft template should be created. Here, the template will be created from 
the draft template previously created. 

 Open the file Training draft A4H from the folder C:\Missler\Group\Template. 

 Use File > Save as, and then save this file in the folder C:\Missler\Group\Template by renaming it Multi-draft 
A5H. 

 Modify the draft frame using Modify element.  

 Select Paper format > Not standard in the drop-down list. 

 Then set: 

 Width: 210mm 
 Height: 148.5mm 
 Name: A5H  

 Click on OK to validate. 

Create the views 

 From the Wood context , start the Multi-draft function.  

 Select Create template, and then Create view. 

 >  
 
Note: Create view is used to position a view of the part or the assembly which will be drafted. 
Three types of views are available: 

 2D view: It is the view configured from the part definition's Drawing tab. By default, it is oriented like the 
sawing up coordinate system. 

 First machining/second machining: These views are configured from the First positioning and Second 
positioning tabs of the part definition's Machining tab. By default these views are identical to the sawing 
up coordinate system, and can be used to generate draft documents for machining. 

 Select View: 2D in the drop-down list and click on OK to confirm. 

 Keep the default scaling factor to 1, and then position the view on the left-hand side of the drawing. 

 Then click on Auxiliary view and position a side view on the right-hand side of the drawing. 
  

 

Creating a multi-draft automatically generates, from a specific template, the draft of several parts 
and/or assemblies by dimensioning them and including information in the title block automatically. 

   

Note 
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Note: You can adjust the dimensions of the view frames 
in order to obtain a better result when calculating the 
part views. 
 

 Start the Modify element function. 

 Select the angles of the frames corresponding to the 
two views and position them as shown opposite. 

 
 
 
 
 
 

Set the template 

 Open the document properties.  

 Go to TopSolid'Wood properties > Draft to adjust the multi-draft. 

 In Elements to dimension, check the following boxes: 

 Dimension drawings to dimension the part views. 
 Part dimensions to dimension the part dimensions. 
 Edge dimensions to place notes on the part's edges. 
 Codification to note the edge codifications on the part. 

 Uncheck all the other boxes. 
 
Note: To calculate the scale factor, two options are available: 

 Free scale factor: The draft scale factor is calculated as accurately as possible, according to the size of the 
view, the title block and the dimensions. A rounding value can be used to adjust the resulting scale factor 
in order not to get inconsistent scale factors (for example, 0.127 rounded to 0.1). 

 Scale factor chosen in the list: The scale factor is first calculated as accurately as possible, but the scale 
factor used is the nearest lower one defined in the list. 

 Enable the Free scale factor option. 

 Enter Rounded value: 0.1. 
 

 Check the Scale factor given by extend of views option to position the 
views in the previously adjusted frames. 

 Validate the window with OK. 
 

 Use the Delete element function to delete the text Draft name. 

 Start the Insert function.  

 Select the title block, and then the box in which the text has been deleted. 

 From the drop-down list, select Property > Reference. Click on OK to validate. 

 Select No element. 

 In the positioning window, select Center center and click on OK to validate. 

 Save and close this document. 
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Creation of the multi-draft 

 Open the design document Interior design. 

 From the Wood context, select the Multi-draft function.  

 Set Depth: Multi level in order to view all parts of assemblies. 
 

Note: When creating the multi-draft, it is possible to put on a paper format 
two drafts in lower format. 
For example, as the draft template created is a horizontal A5 format, two 
drafts can be placed on a vertical A4 paper format. 
 
 
 
 
 

 Set Put together all drafts in one document = YES and select Paper format = A4V. 

 

 Click in the graphics area to choose this file. 

 Select User templates > Multi-draft A5H in the list. 
 
All parts made of particle board will be drafted. 

 Tick the Material box and select Particule board in the drop-down list. 

 

 Validate the selection with OK. 

All the parts are then automatically drafted. 

 Save this file in the folder Interior design and rename it Draft of the 
parts. 
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Place the axes automatically 

In a Draft document, it is possible to place the axes of all the drafted circles automatically. 

 From the View context, start the Axes function.  

 Select Projected axis, All views, Automatic and OK. 

 >  >  >  

Note: The All views option is used to place the axes on all the document's views and the Automatic option is used 
to place the axes on all the document's cylinders. 
It is also possible to define a minimum radius and a maximum radius so that the axes are not placed on certain 
cylinders. 

 

Note: The part drafts of a multi-draft behave in the same way as a simple draft. This makes it possible to modify, 
move and dimension the views, or modify the drawings. 

Supplement: Insertion of information on the part in the title block 

 Open the multi-draft template Multi-draft A5H in the folder C:\Missler\Group\Template. 

 Delete the existing title block. 

 Recreate a title block using the Detailing > Title block function. 

 Enter Width: 190mm and Height: 30mm. Select Hook on border to position the title block. 

 Perform a vertical cut at about 35mm from the right-hand segment. 

 Perform: 

 A regular cut on a column and three rows of the two cells so as to obtain the following result. 

 

 A regular cut of a row and two columns on the top left row. 
 A regular cut of a row and three columns on the two bottom left rows. 
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 Using the Insert function, insert the following in the three right-hand cells: 

 the logo 
 the folio number (i/n) 
 the scaling factor 

 

Note: To insert additional variables in a title block, first create a bill of material in order to retrieve the 
information in the title block. 

 From the Wood context, start the Multi-draft function. 

 Select Create template, and then Create bill of material. 

 In the Group tab, select the General part BOM template, and then click on OK to confirm. 

 Click any two points to the left of the template to place the BOM. 

 Click on OK to confirm. 

 In order for the BOM not to be displayed during the multi-draft, use the Mode/Visibility function and select 

the title block and the two points you just clicked to hide them.  

 Start the Insert function.  

 Select the title block, and then the upper left-hand cell. 

 Select BOM property in the drop-down list.   

The different columns of the BOM are available. 

 Select Designation.   

 Select No element.  

 Set Fast choice > Center center to center the text in the cell, and then click on OK to confirm. 

 Select the other cells to insert the information below: 

  
 

Note: As there is no information to be displayed at the moment, the variables are shown as – (dash). 
 
In order to make the reading easier, it is possible to add text with the variables. 

 Using the Modify element function, modify the Part_length variable (lower left-hand cell). 

Note: The variable is displayed between the symbols < and > as follows: 
<text_displaying_bill_of_material_information_n> 

 Insert Length = before the variable.  
Length = <text_displaying_bill_of_material_information_6> 

The text Length = will be displayed before the variable. 
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 Repeat the operation in order to obtain the following title block: 

  

 Open the document properties.  

 Open the Table/Bill of material > Bill of material section. 

 Check Automatic update of bills of material and click on OK to confirm. 

 Save and close this file. 

 Open the file Interior design.top. 

 Restart the multi-draft by following the same procedure described on page 109. 

The information relative to the parts are then automatically included in the title block. 
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Exercise 14: Project configuration 
 
 
 
 
 
 
 
 
 
 
 
 

 
Note: Three different functions allow you to modify the elements inserted in a project: 

 Define multiple parts: Used to modify all the characteristics of several parts, in place or belonging to 

components, in a single operation.  

 Edge configuration: Used to modify the panel edges.  

 Laminate configuration: Used to modify the panel laminates.  
 
Edges and laminates can be configured in the assembly only if they have been made modifiable in the assembly 
via this same configurator from the template document. 

 Open the project Interior design.top. 

Configuration of components 

 From the Wood context, start the Define > Define multiple parts function.  

 Select Main assembly to take into account all the parts of the assembly in the configurator. 

 
 
The multiple parts definition window opens.  
The left pane of the window (the right pane is currently hidden) allows you to select the parts to be configured. 
Three selection modes are available: 

 Select manually: The parts can be selected directly from the graphics area or from the bill of material with 
a right-click > Select. 

 Select by criterions: This selection allows you to select parts according to one or several criteria, among 
those available in the software (Type, Material, Coating, Thickness and Property). 

 Select by properties: This selection allows you to select parts according to one or several properties. 
  

 

Once a project is complete, some functions allow you to configure it. 
For example, you can modify the part material or the panel edges without modifying the library 
template. The configured elements are then specific to that project. 
 

   

Note 
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The bill of material of the multiple parts definition displays the rows for parts of different colors depending on the 
element: 
 

Color Type of element Information 

Blue Part with cutting-up  

Yellow Part without cutting-up 
A part without cutting-up cannot be 

configured at the same time as a 
part with cutting-up. 

Yellow Assembly 
An assembly cannot be configured 

at the same time as a part. 

Green 
Parts/Assemblies currently being 

configured 
 

Gray Single unit assembly of one part 
A single unit assembly of one part 

must be configured from its 
component part. 

 Select the Select by criterions mode. 

 Check the Material box and select White in the drop-down list 

 Then check the Property box and select the Designation > Fixed shelf property. 

 

 Select the Configure button to configure the selected parts.  
 
Note: When configuring parts via the Define multiple parts function, some properties can display No 
modification. This means that, for this property, the parts being configured do not have the same value. 
It is then possible to: 

 Leave the No modification value: Once changes have been made, each of the parts will keep their original 
value on this property. 

 Replace the No modification value with another value: Once changes have been made, each part will take 
the new value applied to this property. 

 
Once the parts have been configured, the right pane of the window appears. 

 Open the Material tab. 

 Select the material TopSolid'Wood > Panels > Colors > Olive. 

 Select Apply to apply the modifications.  

 Close the right pane manually.  
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 From the graphics area, select the tops of the two lower cabinets manually as shown below. 

 
 

 Select the Configure button.  

 Open the Material tab. 

 Select the material TopSolid'Wood > Panels > Woods > Panel beech hearted. 

 Select the Apply button to apply the modifications.  
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Modifying the material of undefined elements 

Note: The undefined elements such as the floor and walls cannot be modified via the Define multiple parts 
function. 
 

 Start the Attribute > Material function.  

 Select the Matter Coating Finishing button, and then the Material list 
button. 

 >  
 

 From the Material tab, select the material TopSolid'Wood > Building > 
Tiles > Tile 30 rectangular. 

 From the graphics area, select the floor to apply the material onto it. 
 

 Then select the material TopSolid'Wood > Building > Concretes > 
Concrete 05 and apply it to the poles in the interior design. 

 

 Validate the window with OK. 
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Notes 

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  



Notes  TopSolid'Wood Advanced 

126   Missler Software 

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  

 ..........................................................................................................................................................................................................................................................  



TopSolid'Wood Advanced  Individual course evaluation form 

Missler Software   127 

  
 ..

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
..

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

..
..

...
...

...
...

...
...

...
...

...
...

..
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

...
...

  

0 1 2 3 4 5 6 7 8 9 10 
 

Individual course evaluation form 
(To be completed and returned to the training instructor at the end of the course) 

TopSolid'Wood – Advanced 
 

Name :  ..........................................................................................................................................................  

Company :  ..........................................................................................................................................................  

Date(s) from  ................................................................  to  ............................................................................  
 
By completing this individual evaluation form, you are helping to improve the quality and usefulness of the training provided in the future. Please complete it 
carefully. 

 
Number of people during the course:  Onsite at your company? YES □ NO □ 
 
 GENERAL ASSESSMENT  Poor Average Good Excellent 
 Overall, this course has been: □ □ □ □ 
 

What grade would you assign?  

 
 LOGISTIC   Poor Average Good Excellent 
Orientation (quality, organization, user-friendliness, etc.) □ □ □ □ 
Physical setup (room, materials, etc.) □ □ □ □ 
 
 TRAINING  Poor Average Good Excellent 
Instructor's teaching method □ □ □ □ 
Group relationship (participation, sharing of experiences) □ □ □ □ 
Quality and clarity of educational materials (documentation) □ □ □ □ 
Balance between Theory and Practice □ □ □ □ 
Consistent presentations with what has been announced □ □ □ □ 
Training Content □ □ □ □ 
 
 DURATION  No Somewhat no Somewhat yes Yes 
Does the overall duration of the course seem appropriate? □ □ □ □ 
If no, was it? Too short □ Too long □ 
 
 PACE   No Somewhat no Somewhat yes Yes 
Does the overall pace of the course seem appropriate? □ □ □ □ 
If no, was it? Too slow □ Too fast □ 
 
 USE OF ACQUIRED KNOWLEDGE IN THIS TRAINING  No Somewhat no Somewhat yes Yes 
Have you found this training to be useful in your work? □ □ □ □ 
Do you think you can put the acquired knowledge into use quickly? □ □ □ □ 
Do you believe that you have achieved your objectives  

upon completion of this course? □ □ □ □ 
 

Comments and suggestions:  ..........................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  

 .........................................................................................................................................................................................................................................................  


